TCCoA Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,390 Posts
Discussion Starter #1
Hi, i just went to Napa to get a 180 thermostat, that im gonna intsall with my chip, well, it has nothing on the box about it being a 180. All it has is a part number #139. So i entered the part # at napa's website, and I got 3 different t-stats, two 180's and a 196. How do I know which one mine is? O yeah, do I need a new gasket for it?
 

·
MaleWhore
Joined
·
2,640 Posts
that code probably means that its a t-stat....go back to where u bought it and ask what it is...and i dont know if u need a new gasket...but i would get a new one just in case the old one is bad...then if it isnt...turn it back
 

·
Registered
Joined
·
1,212 Posts
If my memory serves me right that's the right part number. Is the box it came in red, black and white? I can't remember the manufacture name. The 4V uses the 109 so don't let them give you that one thinking a 4.6 is a 4.6.
 

·
Registered
Joined
·
1,390 Posts
Discussion Starter #5
It's 139. And yes, the box is red, black, and white.
 

·
Moderator, Iowa Chapter Director, Uber Luber, TCCo
Joined
·
8,978 Posts
the temp is usually stamped into the t-stat itself. Take a look at it and see if it's on there anywhere.
-Thomas
 

·
Registered
Joined
·
1,390 Posts
Discussion Starter #8
All it says is 54mm, and to 1rad. ???
 

·
Registered
Joined
·
1,390 Posts
Discussion Starter #9
Oh its a NAPA one, by the way. If I get the motorcraft one instead, can I put my chip in with the stock thermostat so I don't have to wait?
 

·
Registered
Joined
·
1,196 Posts
Yeah, you can put the chip in b/f the t stat. I had my chip in for prob 4 months or so b/ fi got around to putting a t stat in. still runs...


joe
 
1 - 10 of 10 Posts
Top