TCCoA Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2,008 Posts
Discussion Starter #1
So after 5 years I'm finally getting my tbird back on the road and I'm noticing the car wander back and forth some at highway speeds. car has 101k on it and all the front suspension was replaced 5 years ago before it was put away. I did get the car aligned back in the day. Where would you guys start? Rack and tie rods are original as far as I know. There is no knocking or noises coming from the front. Rear suspension is original and a little noisy.

David
 

·
Registered
Joined
·
484 Posts
Could be a bit of slop in the front or the rear. But more than likely it's just worn inner and outer tie rod ends. The timings right as milage. As are the symptoms.

Have a competent mechanic you trust inspect it and grease every thing while he's under there. If it's been 5 years have him really look it over. These cars a a lot of rubber in the between the front and rear suspension. And it's getting old
 

·
Premium Member
Joined
·
448 Posts
The local Goodyear in my area does free alignment checks. During that check, they look for any worn components that could affect the alignment. I can then do my own parts replacement and come back. No charge until an actual alignment is performed.
 

·
Registered
Joined
·
2,008 Posts
Discussion Starter #4
unfortunaetly no goodyear around here to do it for free so I'm paying $30 for a 70pt inspection. let's see what they find. thanks guys
 
1 - 5 of 5 Posts
Top