TCCoA Forums banner

1 - 7 of 7 Posts

·
V6 Bird
Joined
·
603 Posts
Discussion Starter #1
i have a 95 thunderbird here for sale, i just replaced the trans in it, and now having problems with a sensor i just replaced the mlds sensor or the neutral safety switch. i have not had the codes read, i just dont want to deal with this car anymore and i am looking to get at least 1,000 dollars for it i am firm on that price i paid 1200 for it when i got it.
 

·
V6 Bird
Joined
·
603 Posts
Discussion Starter #3
well it is a brand newer trans from a member of this forum, i just got it installed thrusday, everything was fine with the trans the first day then the second day the trans decided while i was driving to pop out of gear into neutral and then back into drive and then wanted to start flashing the o/d light well i just went by what i reseached on the forum and what i was told it might be, and i replaced the MLPS sensor/neutral safety switch. well put that on yesterday and that still did not fix the problem, so now i am clueless what it might be. i really dont want to sell it, but i really want to find out what is going on here.
 

·
Registered
Joined
·
238 Posts
trans

I honestly dont know enough about automatics to diagnose the problem but, to me it sounds like either a pump or an accumulator problem.
 

·
Registered
Joined
·
275 Posts
do you still have the car for sale?
 

·
Registered
Joined
·
238 Posts
Isnt there a possibility that the filter (in the bottom of the pan) has slipped off of the pick-up tube, and the tranny is starving for fluid? Is the problem worse on corners? Just a thought.
 
1 - 7 of 7 Posts
Top