TCCoA Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1,164 Posts
Discussion Starter #1
I have for sale a complete instrument cluster from my 1997 Thunderbird. I recently converted my T-Bird to use the '94-'96 style instrument cluster, so I have no need for this any longer. I'd like $40 shipped for it.

I have noticed a few times in the past the speedometer needle did not start registering the vehicle speed, from 0, until the car was traveling roughly 25 m.p.h.; after that, it seemed to function normally. It has been almost a year since I noticed that happening, but I just wanted to be honest about that - just in case. All the other gauges have always operated perfectly.

Also, and I have no idea at all if this part is even still available from Ford, but the clear lens on this cluster is in just about pristine condition. It was replaced by me in April or May of 2009, right after I bought the car, with a brand-new lens from a Ford dealer. I've always been very "anal" about how I've cleaned it, so it has very, very few of the fine scratches on it that those things normally get from wiping them when they're dirty or dusty. I'll also go over it once with Mothers Scratch Remover (that stuff worked WONDERS on the lens of the '96 cluster I got from a junked T-Bird; it had many, many fine scratch/swirl marks, and I was able to make it look almost brand-new!).

If interested, shoot me a P.M. I'll accept PayPal payment. Thanks.

Dennis

<a href="http://s1383.photobucket.com/user/dmw4814/media/Mobile%20Uploads/2015-05/IMG_20150509_225308_zpsmn4rvlcz.jpg.html" target="_blank"><img src="http://i1383.photobucket.com/albums/ah283/dmw4814/Mobile%20Uploads/2015-05/IMG_20150509_225308_zpsmn4rvlcz.jpg" border="0" alt=" photo IMG_20150509_225308_zpsmn4rvlcz.jpg"/></a>

<a href="http://s1383.photobucket.com/user/dmw4814/media/Mobile%20Uploads/2015-05/IMG_20150509_225333_zpsvo7wtm1d.jpg.html" target="_blank"><img src="http://i1383.photobucket.com/albums/ah283/dmw4814/Mobile%20Uploads/2015-05/IMG_20150509_225333_zpsvo7wtm1d.jpg" border="0" alt=" photo IMG_20150509_225333_zpsvo7wtm1d.jpg"/></a>

<a href="http://s1383.photobucket.com/user/dmw4814/media/Mobile%20Uploads/2015-05/IMG_20150509_225341_zpsqysqpts6.jpg.html" target="_blank"><img src="http://i1383.photobucket.com/albums/ah283/dmw4814/Mobile%20Uploads/2015-05/IMG_20150509_225341_zpsqysqpts6.jpg" border="0" alt=" photo IMG_20150509_225341_zpsqysqpts6.jpg"/></a>

<a href="http://s1383.photobucket.com/user/dmw4814/media/Mobile%20Uploads/2015-05/IMG_20150509_225349_zps8w8dhsuo.jpg.html" target="_blank"><img src="http://i1383.photobucket.com/albums/ah283/dmw4814/Mobile%20Uploads/2015-05/IMG_20150509_225349_zps8w8dhsuo.jpg" border="0" alt=" photo IMG_20150509_225349_zps8w8dhsuo.jpg"/></a>
 

·
Registered
Joined
·
114 Posts
I have for sale a complete instrument cluster from my 1997 Thunderbird. I recently converted my T-Bird to use the '94-'96 style instrument cluster, so I have no need for this any longer. I'd like $40 shipped for it.

I have noticed a few times in the past the speedometer needle did not start registering the vehicle speed, from 0, until the car was traveling roughly 25 m.p.h.; after that, it seemed to function normally. It has been almost a year since I noticed that happening, but I just wanted to be honest about that - just in case. All the other gauges have always operated perfectly.

Also, and I have no idea at all if this part is even still available from Ford, but the clear lens on this cluster is in just about pristine condition. It was replaced by me in April or May of 2009, right after I bought the car, with a brand-new lens from a Ford dealer. I've always been very "anal" about how I've cleaned it, so it has very, very few of the fine scratches on it that those things normally get from wiping them when they're dirty or dusty. I'll also go over it once with Mothers Scratch Remover (that stuff worked WONDERS on the lens of the '96 cluster I got from a junked T-Bird; it had many, many fine scratch/swirl marks, and I was able to make it look almost brand-new!).

If interested, shoot me a P.M. I'll accept PayPal payment. Thanks.

Dennis

...
Good price--I just paid double that for a 95 cluster. I hope it works when I install it!
 

·
Registered
Joined
·
1,164 Posts
Discussion Starter #3
Good price--I just paid double that for a 95 cluster. I hope it works when I install it!
I guess I got lucky - I paid just $37 for the '96 instrument cluster I got from the local Pick-a-Part here in Phoenix!

Dennis
 
1 - 3 of 3 Posts
Top