TCCoA Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter #1
Hey guys i just bought an 2000 taurus. the guy said it idled rough and that it was probably missing. drove it and there was no check engine light on, thought that was odd. bought the car, get about 5 miles from my house and the light came on. so i now know he cleared the codes. anyway here are a few questions.

1. code came up miss on 6 cylinder. changed the plugs and the coil for that cylinder (COP). nothing got better. Leaves me to believe that its an injector?? Could anything else be the problem? Its got the DOHC motor. it runs good at high speeds but like crap at lower speeds.

2. speedo stopped working and the check tranny light came on.... but once the speedo starts working the light goes off. the car seems to shift good normally. Could this be caused by something? or am i screwed and it be the tranny? thanks for any help.
 

·
Registered
Joined
·
975 Posts
I'd register over at taurusowners.com for more info, but in a nutshell...

Miss on cylinder 6 could be an injector, the circuitry for the injector, in a worst case the ECU, or a plug/COP. I know you said you replaced it; however, I'd try swapping it over to #3 and seeing if the issue follows it, if it does its still a COP or plug, if not injector (which can also be swapped over to #3) or wiring, possibly ECU. Will need more info (like mileage) to make a more accurate guess.

Also get the exact codes and put those up.

As far as the speedo not working it could be the neutral safety switch (MLPS) or again wiring or connector, the VSS would also be high on the list of things to replace as it is common on Duratecs to go bad.
 

·
Registered
Joined
·
4,312 Posts
Do a compression check on cylinder in question - a loss of compression can also cause a misfire if it isnt a bad plug / wire / fuel injector.
 

·
Registered
Joined
·
604 Posts
Since you have a COP ignition system, I assume that it's also DIS? If so, have you tried swapping out the DIS module?
 

·
Registered
Joined
·
2,435 Posts
I had a tauras with this motor and the computer was bad the injecter driver had gone bad on one of the cylinder u need to check for a pulse width
 

·
Premium Member
Joined
·
5,862 Posts
Since you have a COP ignition system, I assume that it's also DIS? If so, have you tried swapping out the DIS module?
There is no DIS module. The COPs are directly triggered by the ECM on this engine.


 

·
Newbie
Joined
·
5,650 Posts
Since you have a COP ignition system, I assume that it's also DIS? If so, have you tried swapping out the DIS module?
The definition of DIS is Distributorless Ignition System, so having coil packs or COPs means it won't have a distributor. The DIS/EDIS modules disappeared in 96 (except for the Windstar) when to allow better functionality of the IDM and misfire monitors.
 
1 - 7 of 7 Posts
Top