TCCoA Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
118 Posts
Discussion Starter #1
well im due for a new motor & tranny or car soon..... anyways im the type where i want to kno y its acting the way it is b4 i replace it...so if ya'll can tell me y my car is doing what it is doing would be appreciated.. first off, i kno it has a lifter tap.. at slow speeds & under hard acceleration its tapping alot & loud inside & out.... um it hesitates alot... the rpm's will shoot up but car takes a few seconds to catch up & take off... when i first start it i have to let it warm up b4 i drive it...if i dont it'll run like crap... (it wont let me go out of second gear unless its really warm)... um, sometimes the tranny skips....i'll be driving & crusing at about 50-55mph & the rpm's will shoot up about 500rpm's for a few seconds then it feels like it shifted but it doesnt... between 25 & 45mph when O/D is on, car will shake & jerk vionently. but when its shaking i TURN OFF O/D & shaking & jerking stops like it never happened... when i turn radio on i hear a loud whining noise but when i turn it off it stops.. when i shift from park or nuetral to drive or reverse, it takes a few seconds to allow me to go...wile driving it'll start to jerk & shake & i put it in nuetral & rev it up to about 4g's & hold it there for a few seconds then shift back into drive & it'll be fine.. ( my uncle said the cats get clogged & by doing that it cleans them) idk... this is my first bird & i kinda want to keep it as my project car...but once again idk... i want a v8 but idk... money is tight as with almost anyone... this will end up being my winter project ... whats wrong with car??? thanx everyone..
 

·
Banned
Joined
·
36 Posts
sounds like you have T/C slip... check your transmission fluid... is it pink? does it smell burned? also, check your IAC valve, and your TPS.... cleaning your MAF might help.


T/C = Torque Converter
IAC = Idle Air Control Valve
TPS = Throttle Position Sensor
MAF = Mass Air Flow Meter



i say drive it until it NEEDS to be replaced and have a rebuilt tranny along with a new engine (single or splitport, w/e u decide to do) and stay auto.. upgrade your driveshaft, rearend (you need a trac-loc, not the pos 7.5 open rear) and your halfshafts... you'll be golden... and you will hardly put a dent in that 6 grand you got.
 

·
Registered
Joined
·
1,112 Posts
I think you have a problem with your transmission, not your motor. It sounds like it is probably electronic in nature, which would be the best thing. If it is mechanical, you will probably need a complete rebuild. I would suggest that it could be the MLPS (manual lever position sensor). I don't know how to check it, but I know that they do go bad. Maybe you can get one from a junkyard and try swapping it. It could also possibly be a problem with the computer, since the 94-97 transmissions are computer-controlled. There is also the possibility of a bad connection or shorted wiring. Maybe check the connectors and wires to the transmission and clean up and corrosion that you find, and retape any chafed wires.
 

·
Registered
Joined
·
3,783 Posts
check your trans fluid also. clean the maf. check the oil level. change filters (fuel too). does it have an aftermarket radio?
 

·
Registered
Joined
·
64 Posts
yeah bad ground on the radio, sounds like you have an amp or some aftermarket equipment?. and your tranny is definitely giving you hell, mine did the same thing for about 20K before I had to rebuild it. The first issue sounds like a bad lifter, a good oil change and some lucas would be your best shot at that.
 
1 - 5 of 5 Posts
Top