TCCoA Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
My brothers '90 3.8 T-bird speedo doesn't work and blinkers work when they feel like it. What should I look at? TIA
 

·
Registered
Joined
·
484 Posts
Digital dash or analog? My old 90's digital dash had the internal lighting go out. It was working, you just couldnt see the numbers.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Analog.
 

·
Pedal Faster
Joined
·
2,658 Posts
Sounds like you might have a loose or corroded connector on the back of the gauge pod. Simple to fix, just remove the outer trim piece, then the gauge pod, then check out the connections on the back. Might be as simple as that.
 

·
Registered
Joined
·
1,112 Posts
By blinkers, you mean turn signals, right? If so, I would recommend to check the multi-function switch (controls turn signals, high/low beams, wipers, etc.). Checking it's a little complicated, but I could dig out my manual and tell you how if you have a multimeter and don't have a good MFS to swap in.

For the speedometer, there's only a few things it could be.

1. The Vehicle Speed Sensor (VSS) on the driver's side of the tranny, near the tailshaft. (My speedometer worked intermittently, because the VSS was somehow sheared in two. I learned that it's supposed to be all one piece when the intact replacement showed up.)

2. The wiring (including connectors) from the VSS to the computer and the gauge cluster (it splits and goes to both).

3. The gauge cluster or speedometer.

4. Instrument panel ground. (But if the other gauges work while the speedometer doesn't, then it's probably not the ground.)

I would advise you to try this: Try using the cruise control while the speedometer is not working. If the cruise doesn't work either, then you know that the problem is somewhere other than the gauge. It's either the VSS or wiring.

edit: If your brother doesn't have cruise control, then you will have to check the VSS and wires visually.
 
1 - 5 of 5 Posts
Top