TCCoA Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
1,779 Posts
Discussion Starter #1
I have a smashed thumb due to a 5lb mallet and laying brick yesterday. So I am trying to get this thing running, with the help of a friend to do the labor.

fuel pump is good....40psi, and holds pressure, so regulator is good. Fuel filter is new. I scanned for codes got following....
-Profile ignition pickup Circuit failure (211)
-MAF sensor voltage low voltage (157)
-HEGO sensor rich bank 2 (177)
-Fuel trim at adaptive rich limit at part throttle lean bank 1 (181)
-fuel pump secondary circuit failure (543)

The car starts up and idles perfectly fine for about 5 min....then starts to run really rough like its got a cam. The engine wont free rev past 3000 RPM when floored or part throttle. When trying to drive it you cant give it any gas. It barley can make it up the slight incline of my driveway.

I have new plugs/wires/cap/rotor on the car. I know its not tranmission problems. The car has 80K on it. 2 older owners and one younger one that I bought it off of that had it for a year.

I tried a known good Mass air meter on it thisafternoon, and it still did the same thing.

TPS?
O2 sensors?

Please help a cripple out, I am new to the 3.8L guys....as you know I am a die hard 4.6 guy for the past 5 years. Chris
 

·
Registered
Joined
·
1,779 Posts
Discussion Starter #2
Bank 1 (Pass side) Plugs are white
bank 2 (drivers side) Plags are black
 

·
Moderator, Iowa Chapter Director, Uber Luber, TCCo
Joined
·
8,978 Posts
check the voltage on the TPS. Could be bad bank 2 o2 sensor. That would explain why it's on one bank and not the other.
 

·
Registered
Joined
·
1,779 Posts
Discussion Starter #4
which two wires (colors) do I check accross on the tps. I cant find out. I know on the 4.6L.

Could an O2 make it not rev past 3000rpm.....I mean it wont even rev past 3000 when I first start it dead cold.
 

·
Moderator, Iowa Chapter Director, Uber Luber, TCCo
Joined
·
8,978 Posts
gray/white - positive
gray/red - negative

Looks like they're the same color wires as the 4.6's tps.
 

·
Registered
Joined
·
1,779 Posts
Discussion Starter #6
what do you think about plugged up cat on one side or the other?
 

·
Moderator, Iowa Chapter Director, Uber Luber, TCCo
Joined
·
8,978 Posts
shouldn't make either side run more rich or lean than the other, but it could explain the 3000rev limit thing...maybe. Why not gut the cats and see what it does? :D
 

·
Registered
Joined
·
1,779 Posts
Discussion Starter #8
well last night I went out and disconnected the drivers side collector....and bam instant performance. The drivers side converter is plugged up. I am going to gut it today, and leave the passenger one intact in hopes of passing emissions testing....with some help of Mr. Rubbing Alcohol. Thanks for all the replys....I also think I am going to replace the O2 on the drivers side as well possibly the passenger side too.

Any ideas what would cause the converter to plug up? Chris
 

·
Registered
Joined
·
1,779 Posts
Discussion Starter #10
well it passed Emissions testing today with one converter gone and one in who knows what condition. I am going to replace the whole assembly next time we get a totalled cat/bird at the lot. Emissions testing is a joke. Chris
 

·
Confirmed V6 Nut
Joined
·
2,261 Posts
Why not get a pair of high flow universal cats and be done with it?

I got two cats for $75 shipped to my house. I'll get them put in when I get the proper pipes since I'm going up in size from stock.
 

·
Registered
Joined
·
1,779 Posts
Discussion Starter #13
High flow cats may pass the visual....but thats not what I am interested in. They have to pass the real test.
 
1 - 13 of 13 Posts
Top