TCCoA Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi Guys,

I am re-installing the 4.6 engine in my 95 thunderbird after doing some work on it. Since its easier to install with the exhaust manifolds attached I can't really see how to line my engine mounts up. I am trying to lower the engine and line up the little hole in the mount plate onto the studs sticking up on the mounts. Its like trying to thread a needle in a haystack that you can't even see in the first place. Does anyone have an easier way to do this...lol? Pictures will help also.
 

·
SuperNewbie
1995 Thunderbird LX 4.6 red
Joined
·
3,011 Posts
Did you install new mounts while the engine was out? If so most of the time you have to modify the mount to make it fit on the K member correctly.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
No I should have. I didn't know how difficult it was lowering the engine onto the mounts while they are already in the bay, so after Matt's suggestion, I still had the engine on the hoist; so I lifted it back out and installed them then. Now after hours of struggling and bad words I have one lined up - I will get back on it tomorrow.

I am curious you mentioned modifying the new mounts to fit on the K member...what type of modification do you usually do with yours?
 

·
Super Moderator
Joined
·
5,417 Posts
I am curious you mentioned modifying the new mounts to fit on the K member...what type of modification do you usually do with yours?
What SOME motor mounts require is trimming the through bolt to clear the motor properly. That is, the one top to bottom.

RwP
 
  • Like
Reactions: supergordo
1 - 7 of 7 Posts
Top