TCCoA Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
385 Posts
Discussion Starter #1
My low coolant light comes on and has just recently started coming on, it happens everynow and then. I can cut the car off and it wont come back on for a day or so. now I did check the connections to the sensors they are good, I checked the fluid level its good I also checked for oil in the water and water in the oil there is none of the bad stuff. I also ran the blown head gasket test that checks for exhaust in your radiator and that was negative. I have a pi intake with the sensor tapped on the crossover, the only things I have not done was run a pressure test and change the cap or sensor, what should be my next move.
 

·
Registered
Joined
·
1,061 Posts
sounds like the sensor in the overflow... mines dirty and its throwing the light for "low coolant" ... could be something that simple..
 

·
Premium Member
Joined
·
6,617 Posts
Take the coolant bottle off, cap it, put a handful of rice and a bottle of rubbing alcohol in it. Shake until it's clean then rinse until all the rice is gone.
Alan
 

·
Registered
Joined
·
3,726 Posts
hmm, I need to try that. All my cars you can't see well enough at a glance to get the level, I tried gravel and sand and degreaser that helped but all the compartments used to remove air are nasty looking, and between the different layers in the main chamber can't see through them.
 

·
Registered
Joined
·
359 Posts
This may seem like a stupid question but did all 94-97 Tbirds come with the low fluid warning lights or was it an option?
 
1 - 10 of 10 Posts
Top