TCCoA Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
301 Posts
Discussion Starter #1
My '97 TBird w/4.6 started stalling in gear WITHOUT the A/C on first it was gradual, then it just won't idle at all.
If I turn the A/C on everything is fine, so I figured the TPS had gotten weak so I put in a brand new one and no change.....do I need to reset the computer after I changed the TPS?? because I didn't. Any suggestions?? Thanks!
 

·
The Parts Guy
Joined
·
7,304 Posts
Sounds like the IAC is sticking. Have you tried cleaning it? The EEC commands the IAC to open a bit further when the AC is on, which explains why it would run with the AC on (it was unsticking). Will it start and run with the throttle blade cracked open slightly?

-Rod
 

·
Registered
Joined
·
1,212 Posts
Sounds like the IAC is sticking. Have you tried cleaning it? The EEC commands the IAC to open a bit further when the AC is on, which explains why it would run with the AC on (it was unsticking). Will it start and run with the throttle blade cracked open slightly?

-Rod

+ 1
 

·
Registered
Joined
·
301 Posts
Discussion Starter #4
Thanks very much for the reply!! I have driven it now and it does seem to be a bit better, it does not stall in gear W/O the A/C now.
However it idles right at 500 rpm which is lower than with the A/C on.
With the a/c OFF I can feel a little click in the accelerator pedal when I come off of idle, with the a/c ON I can't feel the click.
Can someone please tell or possibly show me where the IAC is, and may be how to clean it?? Thanks!
 

·
Registered
Joined
·
5,412 Posts
97 4.6 its right in front of your face, find that black box about 4 inches x 2 inches with tubing attaching it to the plenum and the air box... the part on the plenum with the electrical plug on it, thats the IAC, pull it off and give it a carb cleaner bath, than put it back on.
 

·
Registered
Joined
·
5,412 Posts
if that doesn't work I have one with about 3,000 miles on it that I don't really need.... that I guess I could sell you
 
1 - 7 of 7 Posts
Top