TCCoA Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
My 94 LX with the 3.8 engine only has 68k on the odometer. During my normal driving (very light throttle) it feels like it takes off in first and doing a very easy roll out in my condo complex feels like it skips second gear and goes to third. If I accelerate more briskly, everything shifts as it should. I thought maybe I needed to adjust the throttle valve cable, but it doesn't have one. Ideas?
 

·
Super Moderator
Joined
·
12,254 Posts
Fresh Mercon V does wonders. I also highly recommend a J-mod. Lets cover the basics first.

Have you changed the trans fluid? Recently? Ever?

Has the trans ever been opened? Ever replaced the filter?
 

·
Registered
Joined
·
484 Posts
Fresh Mercon V does wonders. I also highly recommend a J-mod. Lets cover the basics first.

Have you changed the trans fluid? Recently? Ever?

Has the trans ever been opened? Ever replaced the filter?
And to add a voice to changing the fluid. Your in Florida where it's warm or even hot most of the year. The heat seems to definetly cause the trans fluid to break down faster. Us guys up north seem to have less of a issue than the members in the warmer states. And the fact that ford approved the addition of a auxiliary trans cooler in the TSB for the 4R70W in the southern most regions would tend to bear that out. If it's never been changed its at least 18 years old at the freshest. 68K or not. So a full drain and fill is not going to hurt. If it doesn't solve the problem your only out the fluid in the pan if you need to drop it again to do a JMod. So depending on how you look at things it may save you some work. And if the fluid is fresh when you drop the pan there's really no reason you can't reuse it.
 

·
Administrator
Joined
·
8,113 Posts
If you drop the pan, let us know if you find this.



I borrowed this from one of your posts Ron! :D

Joe
 
1 - 5 of 5 Posts
Top