TCCoA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
My 95 tbird will on occasion bog in low gear like trans is in low and park at same time , I can let off the gas and try to go again and it works fine, also if you keep pressing accelerator it will release and go fine but does not always do this some days I will have no problems others every time I take off never know what it will do. Please help.
 

·
Super Moderator
1997 Thunderbird 4.6, 1998 Mark VIII LSC
Joined
·
9,578 Posts
When you say low gear, you mean numerically low? E.G. you're in 1st or 2nd and it feels like it has no power?

Or is it this - you're in 4th or 3rd, you hit the gas and it doesn't downshift to 1st or 2nd like it should initially. You take your foot off the gas and hit it again then it downshifts, or if you hold it down then it downshifts. If so then this is caused by a bad TPS.
 

·
Premium Member
Joined
·
649 Posts
bad IAC quite possibly the problem here.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
What I mean is in 1st gear from take off car will not move and engine will not rev up, like if the brakes were locked release the throttle and press again and it works fine also from a stop light sometimes works like it should other times you have to depress the throttle almost wide open then it is like letting trans brake off and trans works like it should.
 

·
PostSlut
Joined
·
13,597 Posts
what all have you done to the car as far as maintenance goes? and how long ago?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Have had the egr valve replaced and changed the tps about 4 years ago other than that just routine maintenance.
 
1 - 6 of 6 Posts
Top