TCCoA Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Ok so, a couple of weeks ago i started having intermittent problems with the tranny not shifting from 2nd gear, but it was only every once in a while and was fine if i pulled over and restarted the car. well recently it has gotten much worse and will now randomly shift itself into 2nd when im already in motion! (scared the crap out me the first time it did it, thank god i was only going about 40) but i have found that if you quickly put it in low then back to drive it 90% of the time will reengage drive and will be fine. i have done some research on this and most fingers are pointing towards the one way clutch, but if the clutch was bad wont it lock you out of the higher gears all together? once it finally engages drive its fine and will cruise sweet as a nut and has no shudder and no lag in shifting or anything, perfectly normal... its almost like there is something wrong with the signal to the tranny to tell it what gear im in or something idk... and before this stuff started happening a couple months ago it used to slip into neutral if i would goose it out of 2nd, but would reengage if i let off the gas... that went away about a week later (was fine under normal driving conditions)... so now i have traded that problem for this new fascinating one... so if any of you have any idea on what this thing could be i would be much appreciative... im just hoping its not the clutches because i already had to have the torque convertor clutch changed and some other things a while back and that was 870$ so i definitely would rather not have to go bankrupt fixing this thing...
 

·
Super Moderator
1997 Thunderbird 4.6, 1998 Mark VIII LSC
Joined
·
9,526 Posts
Sounds like the MLPS.
 

·
Premium Member
Joined
·
1,150 Posts
MLPS and VSS are the first things to test.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #4
Ok cool it sounds like it could be the mlps I'll check that out first :) thanks
 
1 - 4 of 4 Posts
Top