TCCoA Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
3,183 Posts
Discussion Starter #1
I recently got a 87mm maf and mac cia intake.. My MAF is bad, I don't have a chip right now for it. Can it still be used as a replacement?
 

·
Moderator
Joined
·
8,239 Posts
87mm Maf?

What brand is this?

If its a ford OEM maf then the answer is NO you can't drive your car without the proper transfer function.

If its one of those garbage C&L MAF's with the transfer function for your vehicle/injectors then I guess you can drive it without a tune, but you should be saving for a OEM ford maf and chip to do it properly.

JH
 

·
02 Explorer Pioneer
Joined
·
2,880 Posts
KraZy,

I've got a good used stock MAF for a 4.6 I'll send you for shipping costs if you need it. PM me if you're interested.
 

·
Registered
Joined
·
9,966 Posts
JustinH said:
87mm Maf?

What brand is this?

If its a ford OEM maf then the answer is NO you can't drive your car without the proper transfer function.

If its one of those garbage C&L MAF's with the transfer function for your vehicle/injectors then I guess you can drive it without a tune, but you should be saving for a OEM ford maf and chip to do it properly.

JH
the GT MAF can be used without a chip, Aaron K did when he used his 02 Exploder motor and ran something like 15.1...

joseph
 

·
Registered
Joined
·
2,577 Posts
Aaron K. said:
LOL, I dont like your typo, I dont have an 02 "Exploder" motor :D
We'll just see about that on the 10th!!! (LOL)

And as far as I know, you do need a chip to run he 02 GT MAF....

Gee Timb, you've got one of those, too?? I've got a nearly new '96 MAF still in the ford box... I used it for about a week just before I went for the GT...
 

·
Registered
Joined
·
3,183 Posts
Discussion Starter #7
I tryed to put my MAC CIA on and it doesnt seem to wanna work right. It will rev high then rev low off and on for a few mins then die completely. Do I need a chip or what?:leftright
 

·
02 Explorer Pioneer
Joined
·
2,880 Posts
Yeah the one I have that I just mailed to Krazy is compliments of Cam94.
 

·
Registered
Joined
·
2,577 Posts
KrAzyT said:
I tryed to put my MAC CIA on and it doesnt seem to wanna work right. It will rev high then rev low off and on for a few mins then die completely. Do I need a chip or what?:leftright
Mac CAI swap should not affect the EEC at all.. no chip is should be required for that mod. I did not have a chip when I installed mine and had no problems.

You started the thread stating you installed an 87mm MAF.. I'm not familiar with anyone that makes an 87mm, but if you do not have your stock MAF on the car, you will probably require a chip. What MAF do you have on now???

If you have been swapping MAFs back and forth, maybe you should have someone run a scan and check your TPS reading and idle settings....

If you disconnected the battery to reset your EEC, it may take a couple of days of driving to get everything to settle down... When I disconnect my battery, I have loping idle for 2 - 3 days, gradually improving until it finally goes away....

The CAI should not have any affect at all....
 

·
Registered
Joined
·
9,966 Posts
Aaron K. said:
No, when I ran the 15.1 I was using my stock MAF and running a stock EEC.

LOL, I dont like your typo, I dont have an 02 "Exploder" motor :D

ok fine i was wrong...i do that from time to time.:D

joseph
 

·
Registered
Joined
·
347 Posts
Seriously, why do people still insist you can run an MAF that doesn't correspond to the transfer function in your EEC? Yes the car will turn on, yes it will run, however it is very important you get the proper transfer function placed in to your EEC. If you don't understand why, read the tech articles.



The Great Obucina said:


the GT MAF can be used without a chip, Aaron K did when he used his 02 Exploder motor and ran something like 15.1...

joseph
 

·
Registered
Joined
·
2,577 Posts
Derek said:
Seriously, why do people still insist you can run an MAF that doesn't correspond to the transfer function in your EEC? Yes the car will turn on, yes it will run, however it is very important you get the proper transfer function placed in to your EEC. If you don't understand why, read the tech articles.
I have been running an 02 GT MAF in my 1996 4.6L Thunderbird for several months now.. not only does it start, and run, but it runs real good...

There is a trick however, you must have a chip burned accordingly or have your EEC burned accordinly.. You can also use the Lightning 80mm or 90mm MAF with a chip or EEC tweak.

That fact was explained above when I suggested that if he swapped in an other-than-stock MAF, he need a chip........ and both Joseph (who posted the quote you chose) and AaronK (of whom the post was written) pointed out that what you quoted was an error, AaronK did have a chip with the GT MAF
 
1 - 12 of 12 Posts
Top