TCCoA Forums banner

1 - 2 of 2 Posts

·
Moderator
Joined
·
8,239 Posts
Discussion Starter #1
On my brothers 89 sc, with 184k miles he has been getting terrible gas mileage ever since he bought the thing. The motor has been apart, and the headgaskets have been done, so I don't think that gas mileage is giving to "old age".

I drove the car from buffalo to rochester today, which is about 80 miles each way. I got 150 miles out of the last tank, and this is on the freeway out of the boost.

The car has magnecor wires, new ford double platinum plugs, and free flowing exhaust. It has no mods other than this.

The car runs fine, but once in a while I will get a check engine light for the maf, I think the maf is headed south. I have a new maf for it.

So, i'm going to replace the maf, and put a fuel filter in it. Anybody else have any ideas why the mileage is so low?

JH
 

·
Registered
Joined
·
1,112 Posts
Well, O2 sensors could cause bad mileage. I think a bad O2 sensor would generate its own code, however.

One or more of his fuel injectors could be stuck open. I just read about a case where this guy with a '94 4.6 had fuel dripping out his exhaust because of 3 stuck injectors! (See this page.)

Or the computer could be out of whack, but that seems rare.

Or, of course, the MAF is bad. This seems pretty likely since it threw a code! But before you replace it, you might want to check the wiring first! Of course, if you have the replacement already ... well, you know.
 
1 - 2 of 2 Posts
Top