TCCoA Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Well i just rescued a 91 SC from the junk yard. I walked away with the car for 300 bucks, has 130K miles automatic. Interior is clean, exterior needs paint and small body work.


Now the problem


Car runs fine for the most part, however when warm sometimes it start runnning like crap. It begins Idleing funny till the car dies.

When it starts acting up, the RPM gauge seems to go from 800rpms to zero and back up at idle, under acceleration the car seems to "surge".

Parts replaced:

TB and
and idle soleniod sensor.


Any suggestions? Mass air?

these cars have some sort of TFI? (i know in my 5.0 mustangs these can be an issue)

what else can it be?


thanks in advance.
 

·
Registered
Joined
·
16 Posts
believe it or not, the fuel pump could be on its way out, my 89 SC used to shut off all the time when i was ****ing driving down the damned ROAD. oh man embarressing. i put in a new fuel pump and it never happened again. and it only happened when the car was warmed up all the way and its been driving for a lil while. but yeah check that fuel pump and filter while yur at it......'

and WORD OF ADVICE!!!! if you change the fuel pump........figure out how to do it yurself..... get a manual or something!!!! DONT PAY A MECHANIC DAMNIT LIKE I DID!!!!

AND GET AN AFTERMARKTER PUMP PLEASE!!!!!!! they cost just as much as an OEM pump but yur cars factory pump is barely enough for a stock SC. get a 190lph from somewhere anywhere. for 100bucks or something. lata!!

adam


rage racing!!!
MY 89SC!!
 
1 - 3 of 3 Posts
Top