TCCoA Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2,055 Posts
Discussion Starter #1
Hello,

I am borrowing/fixing up a friend's 94 3.8L bird. It is GREEN with a GREEN interior. It's hilarious.

Anyhow, the car runs bad, like it has a miss or something. Upon initial inspection, the entire air intake tract wasn't tightened down, it was loose (like, REALLY loose) at the throttlebody and at the MAF. Tightened it all up, cleaned the MAF, ran seafoam, and it runs a little better.

I bought a set of plugs but I haven't installed them yet. Splitfires. .99c :)

It doesn't feel like it has all the power it should.. "yes, we know, it's a 3.8L", you say. Yes, but it doesn't feel like it's even making the power appropriate for the 3.8L. This is a rebuilt engine with 30k or so on it.

The chassis, on the other hand has 220k or so on it.

Anyhow, yeah, I can't figure out why it's running bad, it isn't throwing a CEL or anything.

I thought I would also raise the point that this car has a Distributorless ignition system (DIS) which I'm not sure whether or not is supposed to be there, because last I checked the 3.8's usually had a distributor... and it also has an electric rad fan... don't the 3.8's usually have a clutch-fan???

Anyhow, back to my point about the tach... it is crazy. It is ridiculous, either it says 500-1200rpm, or it goes backwards down to zero as the revs climb. It's stupid.
Is this a bad tach, or another problem? I am thinking about disassembling the dash and installing another tach since I've got one.

Any input as to what the devil is causing my problems would be much appreciated.

Thanks guys,

Ghost--
 

·
Premium Member
Joined
·
1,372 Posts
I think you have a bad ignition module if it's running ruff and the tach is going nuts.
 

·
The Parts Guy
Joined
·
7,360 Posts
That would be a California Emissions edition 94-95 3.8L NA MN12 that you're dealing with there. Those cars received DIS, where as the 3.8L NA's in the rest of the country didn't received DIS until 96, when they became OBD-II. All of the 94+ MN12's had electric fans, as did the 89-93 SC's and 89-90 XR7's, though those were different.

Anyway, the problem is textbook cam sensor failure. You just need to replace the black plastic cam sensor, don't mess with the stalk going down into the timing cover. Just remove the two screws attaching the sensor to the stalk, and replace with a new sensor. It's super easy, should only take a few minutes.

-Rod
 

·
Registered
Joined
·
2,055 Posts
Discussion Starter #4
Got a pic of where it is and what it looks like??

And what do I need to remove/install it?

Thanks, Rod!

-Ghost
 

·
The Parts Guy
Joined
·
7,360 Posts
This is the best picture I have on hand. The cam sensor is circled in red. Your engine will look quite different (that's my Splitport LX), but the cam sensor is identical, and in the same location. The cam sensor is in the same location as the distributor would be, and the sensor itself is the black plastic cap on the top. I don't remember off hand what size the two bolts that attach it to the stalk are.



-Rod
 

·
Registered
Joined
·
2,055 Posts
Discussion Starter #6
Well, that actually looks reasonably easy to remove!!

I'll try changing that thing.



thanks for the help!
 

·
Registered
Joined
·
2,055 Posts
Discussion Starter #7
Replaced the cam sensor and that didn't do it... :(

Any other suggestions?

If it is an ignition module, that's separate from the DIS coil, right?

The ignition module's a flat thing with a cable on each side, right? Looks like the SC DIS module... right?

Please let me know, thanks,
Ghost.
 

·
The Parts Guy
Joined
·
7,360 Posts
The ignition module is the flat black plastic box all the way to the left in the picture above with one gray 10 or 12 pin connector. That's unusual that it wasn't the cam sensor.

-Rod
 

·
Registered
Joined
·
2,055 Posts
Discussion Starter #9
damnit, i couldnt get online earlier or I wouldve grabbed one of those pieces of crap.

oh, and I put in yet another camshaft sensor and that didnt help either.

i also put in a radiator on this piece of crap car today
 
1 - 9 of 9 Posts
Top