TCCoA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1 (Edited)
I have a issue with my 95 T-Bird, when I first fire it up I can drive around forever
with no problems but if I stop somewhere like say to get gas and then take right back off again the airbag light flashes a 34 code.However if I let the car set for a hour or so and start it again no problem,the airbag light does not flash It comes on momentarily when I start the engine and then goes off and stays off,what the heck? could it be the diagnostic module?

purchased a diagnostic module on line as I am sure there is no problem with the air bag itself or the clock spring,should get the module this coming tuesday!
 

·
Registered
Joined
·
11 Posts
I have a issue with my 95 T-Bird, when I first fire it up I can drive around forever
with no problems but if I stop somewhere like say to get gas and then take right back off again the airbag light flashes a 34 code.However if I let the car set for a hour or so and start it again no problem,the airbag light does not flash It comes on momentarily when I start the engine and then goes off and stays off,what the heck? could it be the diagnostic module?

purchased a diagnostic module on line as I am sure there is no problem with the air bag itself or the clock spring,should get the module this coming tuesday!
same code...I can drive down the rode and put in neutral and turn it off and then start it back up.. it don't come back on. at first I was getting code 36, it has something to do with passenger side resistor. but now im just getting the 34. im keep an eye on it. im thinking it could have something to do with the seat. sometimes it only does it if I crank it and im not setting down.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
I have a issue with my 95 T-Bird, when I first fire it up I can drive around forever
with no problems but if I stop somewhere like say to get gas and then take right back off again the airbag light flashes a 34 code.However if I let the car set for a hour or so and start it again no problem,the airbag light does not flash It comes on momentarily when I start the engine and then goes off and stays off,what the heck? could it be the diagnostic module?

purchased a diagnostic module on line as I am sure there is no problem with the air bag itself or the clock spring,should get the module this coming tuesday!

I installed the new diagnostic module the other day and apparently it was in fact a defective Diagnostic module which caused the 34 codes as i have not seen any codes since.
 

·
Premium Member
Joined
·
5,862 Posts
I just started having this same problem about a month ago.

I, too, am going to try replacing the Diagnostic module! :thumbsup:

Thanks! I'll report back if it fixes my problem, too.
 

·
Super Moderator
Joined
·
10,590 Posts
I just started having this same problem about a month ago.

I, too, am going to try replacing the Diagnostic module! :thumbsup:

Thanks! I'll report back if it fixes my problem, too.
You should look at it; I'll bet it's full of cold solder joints.

It looks like tiny circles around the leads of the parts going thru the board.

If that's the deal, you can apply flux, reheat all the solder joints, and it will be fine.

I use a hot air solder station, but in a previous lifetime, I used a small butane torch; you just have to be better at it, lol.

YMMV...
 

·
Registered
Joined
·
1,646 Posts
Mine doesn't even come on at startup, but randomly comes on or off steadily and does not flash a code. So it's time for a new module.
 
1 - 6 of 6 Posts
Top