TCCoA Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Discovered what appears to be a sensor dangling in the front passenger side of my 95 T-bird... looks like the rubber hoses that held it in place got brittle and fell apart. Anyone know what this thing is? a sensor? I can see what it connects to on the left side with an elbow piece but can't see any broken tube where it would connect to on the right side...
thing-1.jpg
thing-2.jpg
 

·
Registered
1995 Mercury cougar xr7
Joined
·
32 Posts
That the evap canister purge valve. It hooks to your charcoal filter and opens when the ecu commands it to under certain conditions.

You probably have a vacuum leak with it broken like that.
 

·
Super Moderator
Joined
·
11,414 Posts
There are 8 pieces of line in that, get all of them.
Basically, if you haven't fixed it yet, everyone with one of these cars has this problem, if they look.
The hose that's broken is bigger on one end; I put one piece inside the other to re-make it
If it's not fuel vapor rated, it will die in about a year.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
Thanks all for the help! I bought some 1/4" fuel rated hose and hooked it back up. It's thicker hose than what was on it.. I wonder if the broken, brittle hose was just vacuum line.
 

·
Registered
Joined
·
2,355 Posts
What was on there was factory, and likely just vacuum line since they go bad on every car. There are plenty of hoses that last very long on these cars, but that's not one of them.

Al
 
1 - 7 of 7 Posts
Top