TCCoA Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter #1 (Edited)
I'm working on a 1996 Thunderbird with the 4.6 engine. Transmission was shifting fine than all of a sudden with would not go past second gear. 1-2 shift a good with no lag or slipping. I have engine braking in manual 1,along with manual 2. From a take off the car with go 1-2 normally than hold 2nd until 36-37mph and than neutral out. If I engage manual second it kicks back into 2nd. If I keep it in drive while its neutraling out I can get second gear by rasing the rpm but it seem to slide than bump not bang back into 2nd. Also the over drive light does not have any effect during the neutraling not during acceleration. It wont light up with KOEO nor KOER. I have checked the fluid and it seems fine.
 

·
Registered
Joined
·
58 Posts
A couple of possibilities, first might be a bad shift solinoid pack or MLPS not reading correctly, second could be a blown direct clutch accumulator/direct clutch piston cracked, direct clutch housing stripped/cracked, third possibility is a stripped/snapped stub shaft.
Solinoids & MLPS can be serviced in-car, everything else requires removal and teardown/rebuild.
Good luck,

Kevin.
 

·
Registered
Joined
·
2,976 Posts
Right before this happened di you by chance have the car going really, really fast or did you get on it while in overdrive?

Darrin
 

·
Registered
Joined
·
65 Posts
Discussion Starter #4
Would a bad solenoid pack cause the O/D light not to function? I wasn't driving it when this problem occurred but I doubt the driver was doing any hard driving(hes almost 50)
 

·
Premium Member
Joined
·
649 Posts
Would a bad solenoid pack cause the O/D light not to function? I wasn't driving it when this problem occurred but I doubt the driver was doing any hard driving(hes almost 50)
- Best of my knowledge Bad Solenoid would cause the OD Light to Blink provided Bulb is good thereby telling you it's stored a Tranny Code that documents the problem.

- Darrin helped me ID my bad Direct Clutch Drum during my Overhaul, per the Gurus it's a common failure.

& Grumpy old men like me can still do a little hard driving now & then...
 

·
Registered
Joined
·
65 Posts
Discussion Starter #6
Ok well how about the MLPS would that cause dead o.d. light? I did pull the cluster and test the bulb it tested good. Also replaced PCM with a known good one. The trans not shifting is no big deal. Its the O/D light that bothers me. I have changed many birdy trans but dont want to put one in and have the same problem.
 

·
Premium Member
Joined
·
649 Posts
If OD Light never comes on first I'd Check the FUSE.

If Fuse is Blown first suspect is bad O/D Switch in Shifter.

2nd Suspect for blown Fuse is flooded MLPS Connector.

With Tranny not shifting & a good Fuse & OD Bulb I'm not understanading why OD Lite is not blinking - It should be.
 
1 - 9 of 9 Posts
Top