TCCoA Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Help! Turn car to acc and check engine light flashes really fast replaced ccrm and battery still happens anybody have this problem b4?
 

·
Registered
Joined
·
1,088 Posts
Does it start and run OK? I'm pretty sure flashing CEL means you are damaging your catalytic converters (big $$ to replace) so you need to get the trouble codes read ASAP.
 

·
Registered
Joined
·
4,309 Posts
More than likely its anywhere between P0300 to P0308.

Flashing CEL is a "catalyst damaging" indicator, ie; no Spark.

Has nothing to do with the Battery or the CCRM .. the 96/97 PCM has the Ignition Control Module integrated into it, so probably a problem with the Spark plugs, Plug wires, Coil packs or PCM.
 

·
Registered
Joined
·
3,726 Posts
I don't think blinking CEL/SES in accessory is a misfire. It can't do a misfire test unless it is running.
 

·
Registered
Joined
·
96 Posts
Unless it is a stored code???
 

·
Registered
Joined
·
8 Posts
my check engine light is flashing to when i first start it and it goes into high idle. the high idle is about 500rpm faster than normal when it does this for a few second. Its a 91 with obd1. it seems to run fine after though
 

·
Registered
Joined
·
130 Posts
I have a 97 Cougar and I'm having the same problem. I get codes P0430, P0172 and P0173. The "Check Engine Soon" light doesn't flash all the time but, when it does, it runs really rough. A lot of sputtering and the AC starts to blow warm. When it's not flashing, it runs GREAT! Very smooth, great acceleration, nice clean hard shifts. I have the SCT Tuner and it's suppose to have eliminated the CATS and rear O2's from when I had the exhaust headers replaced and the dual exhaust installed. Maybe the program didn't include those but I'm waiting on a call back from where I purchased the Tuner to find out. So those codes and the flashing could be because I have no CATS and rear O2's?
 

·
Registered
Joined
·
4,309 Posts
So those codes and the flashing could be because I have no CATS and rear O2's?

No .. I posted the reason why it flashes over a year ago, further up in this thread.

Flashing CEL/MIL is a "Catalyst damaging" indicator.

Just because your Tune was made to eliminate the rear o2 sensors, and you have no cats, doesnt mean it wont still flash.

The front o2 sensors on your car still function as they are supposed to - giving feedback on the engine rich/lean condition to adjust the fuel trims according to the PCM programming. The reason why your light is flashing is because the o2 sensor is reading way too rich. Not that you have to worry about damaging your cats by washing un-burnt fuel down your exhaust pipes, but you're just wasting gas and losing power. Probably an ignition wire / coil / spark plug problem.

If the MIL/CEL is flashing without the car running, there is likely an issue with the PCM and/or associated wiring / sensors.
 
1 - 9 of 9 Posts
Top