TCCoA Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Takes some time to get up speed .. I take it easy and try not to beat on the car.. I've done regular maintenance under the hood but starting to lose power and runs a bit hotter than usual (not over heating). ..still starts everyday and drives but just rolled 100,000 miles and i think the cats our shot or maybe it's the 02 sensors .. how difficult is it to replace the front 02 sensors...???
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
It could possibly be a fuel pressure issue..
Im not sure how to diagnose it though.. I put a scanner on it and pulled some codes ... Purge valve, system too rich bank 1, oxygen sensor heater circuit bank 2 sensor 2.. also same oxygen code for bank 1 sensor 2... That's why I thought 02 sensors or possibly plugged cats..
 

·
Registered
Joined
·
584 Posts
Does a 4.6's fuel rail have a Schroeder valve? I put a FP gauge on my fuel rail. It just sits there and tells me the psi..
 

·
Registered
Joined
·
1,887 Posts
I would get Motorcraft o2 sensors. Anything made by Bosch doesn't belong on ANY car.

Al
 

·
Registered
Joined
·
200 Posts
I would get Motorcraft o2 sensors. Anything made by Bosch doesn't belong on ANY car.

Al
Who do you think makes the OE motorcrafts?... (worked at Bosch's Planar Sensor (02) plant in college.)
Only two Major companies make O2 sensors, Denso and Bosch

The only difference is that going to the OEM for assembly line install get an extra test on them (0 mileage failures are a huge no no with big dollar charge backs). Anything going for aftermarket install is treated the same. (still two levels of tests).
 

·
Registered
Joined
·
1,887 Posts
Any Bosch branded o2 sensor I have ever seen looks different than a Motorcraft sensor.

I am sure they make good products, just haven't found one to date.

Al
 

·
Premium Member
Joined
·
556 Posts
Fuel filter? Clean the MAF. East cheap things you should do anywoo!
Tap on the cats with a mallet and see if they make crazy noises. And or pull the front 02 sensors if it runs slightly better the cats may be clogged.
 

·
Registered
Joined
·
200 Posts
Any Bosch branded o2 sensor I have ever seen looks different than a Motorcraft sensor.

I am sure they make good products, just haven't found one to date.

Al
The cap was a different part no. body is the same as is the internals. For a Ford Motorcraft part we would put one pigtail on (the factory one). For autozone generic we'd cut the testing pigtail off and ship it with various "solder yourself" pigtails.
 
1 - 9 of 9 Posts
Top