TCCoA Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
98 Posts
Discussion Starter #1
I have a 96 tbird lx 3.8 the motor has 70,000 miles on it it runs good, its jsut i went to check the motor oil and and it seemed low like half of the hatch marks so i put almost a half of quart of quaker state 10-30.

I dont get it where does the oil go theres no leaks, no smoke etc. is 10-30 to thin or what?
 

·
Moderator, Iowa Chapter Director, Uber Luber, TCCo
Joined
·
8,978 Posts
well just for future reference, on a ford dipstick, the oil is full when it is halfway up the dipstick. Do you change your own oil?

It is natural for a motor to burn oil, in fact, it's supposed to. If it burns too much you have a problem. How long since you changed the oil, and is this the first time you checked it since then?

-Thomas
 

·
Registered
Joined
·
1,890 Posts
How long had it been since you last checked the oil level.
 

·
Registered
Joined
·
98 Posts
Discussion Starter #4
Ok umm well I think its been a long time like 3-4 months or more and traveled to mailbu couple of times after doing a tuneup myself, after u guys say that its probably time for a oil change and what weight of oil i sould get?
 

·
Registered
Joined
·
1,890 Posts
Then if its just half a quart thats completely normal. After 3-4 months you should do a change. Just stick with 10-30. I use that all year round and the temps go from -35 to 30 above, never had any trouble and burn about .5 quart a month (my car has over 200000 miles on it though)
 

·
Registered
Joined
·
208 Posts
hmmm i dont know, but i have no oil pressure when i idle...i am no longer driving the car
 

·
Registered
Joined
·
1,890 Posts
First check the guage it could be faulty. Had the same thing happen to my old Capri. No pressure at idle but would pick up as the car accelerated. Problem was a bad bearing. Drove it like that for about 2 months till I sold it.
 

·
Registered
Joined
·
208 Posts
my mom and my mechanic (also my boss) think i got a piston slappin and its from dirty oil...grrrr!
 

·
Moderator, Iowa Chapter Director, Uber Luber, TCCo
Joined
·
8,978 Posts
does your engine makes a ticking noise?
 

·
Registered
Joined
·
208 Posts
mine? not that ive heard
 

·
Registered
Joined
·
1,890 Posts
Have you looked at the oil? Is there any sign of contamination?, milky looking oil from water or anti freeze? Or gas getting mixed with the oil?
 

·
Registered
Joined
·
208 Posts
very bad contamination, its as dirty as a pig farm...we think the oil was dirty before i got it and when they changed it and the filter it didnt flush like it should of...so now i got a piston slappin we believe
 

·
Registered
Joined
·
1,890 Posts
You could try to change the oil and put a can of engine flush in there and see if it makes a difference. Cant promise ya that it will work, but you could have a clogged oil gallery.
 

·
Registered
Joined
·
208 Posts
yea i gotta talk to my mom about it...she wants me to sell the car anyway due to crappy gas mileage/insurance and theres no way she'll let me get anything I want
 

·
Registered
Joined
·
1,890 Posts
With a little TLC, and as long as there is no serious damage, the car will run good for along time and the gas mileage isnt too bad after a good tune up. Mines gettin close to 210,000 miles and still gets about 20MPG in the city.

I dunno what the insurance is like there, but one plus for these cars, if you get into a bad wreck they hold up pretty well when it comes to protecting the driver and passengers.
 

·
Registered
Joined
·
208 Posts
its been through more tuneups than i can count since i got it in august and the gas mileage is still crappy...its on its 2nd engine too, my mom doesnt get the fact that our insurance isnt high because of the bird its high because of ME...lol
 

·
Registered
Joined
·
1,890 Posts
Was the engine used?
 

·
Registered
Joined
·
208 Posts
yea, first one was blown
 
1 - 18 of 18 Posts
Top