TCCoA Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
118 Posts
Discussion Starter #1
Just gonna shorten this. Swapped in a 99 trans into my 94 cougar. I have also done a 97 ecu swap. I'm using a 97 intermediate harness with 02 sensors integrated, I've also changed the tcc solenoid to 97. I just swapped in the 97 harness tonight and for some reason my transmission will shift into 1st and 2nd..then it will stay in second and seems like it will go into first and stay until full stop. Accelerate and it will again go into first then second and then back to first. It seems like it wants to go into 3rd but it will not. I know I've repined harness correctly and I'm sure there's no issues with wiring touching each other like they tend to do when the harness gets filled with oil and then the wiring starts to bloat and flake off. I'm tired and if anyone has some insight on this issue please let me know. Here's a list of upgrades done to my cougar for more insight:
99 4r70w out of a mustang gt. I've had it for two years and its had no issues untill the intermediate harness swap. 96-97 npl3 ecu,pi swapped h/c/i, and trac lok 3.27 rear end from t bird sc. Please feel free to ask for any other info. I have all on hand and am able to take pictures. Thank you for your time.
 

·
Registered
Joined
·
3,726 Posts
So for the last two years you have had a 94 Cougar with a 97 ecu and a 99 4r70w and it worked fine. Then you swapped the intermediate harness and the TCC and now you get the problems shifting?

Is the OD light blinking, have you tried checking for any codes (I am not sure what code readers will pick up transmission codes, my XCALII does but any of the ELM327 wired or bluetooth along with Torque won't)?

I assume the PCM swap also included the harness swap? I see a number of items that are different between 94 and 97, only TCC for the transmission swaps pins on the PCM though.
 

·
Registered
Joined
·
118 Posts
Discussion Starter #3 (Edited)
Yes that is correct. I've had this swap since 2012. Yes everything including pcm was swapped. The only wiring that's 94 are the female connectors in the dash going to the male connectors for transmission intermediate harness. I've just double looked wiring in that area and everything is matched up. White/pink to white/pink, red/blue to red blue etc. Maybe I'm over looking something?? OD light not blinking because the dash fuse is out of car. I've yet to fix that issue. Getting fuses now. Tcc solenoid has been swapped since 2012 btw. Only thing new is the intermediate harness.
 

·
Registered
Joined
·
3,726 Posts
Here is the diagram for a 97 to the transmission (I didn't include the other things in the harness):
97_thunderbird_transmission by dabangsta, on Flickr

Here is the one for 94:
94_thunderbird_transmission by dabangsta, on Flickr

and here are the PCMs, the TCC signal is a different pin between the years, otherwise it looks like all other transmission related ones are the same, including the shift solenoids.

1994 PCM:
94_thunderbird_4.6_PCM by dabangsta, on Flickr

1997 PCM:
97_thunderbird_4.6_PCM by dabangsta, on Flickr
 

·
Registered
Joined
·
118 Posts
Discussion Starter #7
I see that there are two purple/orange wires located in dash female harness. I cut wiring to soon to determine which went to which. Big mistake I'll never make again. One purple and orange wire goes to the mlps, and the other for shift solenoid #2. Can anyone send me a pinout diagram for these connectors located in dash in front of shifter knob?? Can't find this diagram on the forum..
 
1 - 7 of 7 Posts
Top