TCCoA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter #1
Im going to try to work on my a/c before it starts to warm up again. Everything works on the console, vent, heat, and defrost. When i first got the car, my gfs dad jumped the compressor so i dont think its bad. I think there is a bad switch somewhere. He said something about a pressure switch? Any thoughts on what could be wrong?
 

·
Registered
Joined
·
1,430 Posts
i had this exact same thing happend to me man. My A/C stopped workin out of nowhere, there was freeon in it. Jumped the compressor and it turned on. Replaced the A/C low pressure switch and it solved it, try that or the high pressure switch. Fixed the a/c for $15
 

·
Registered
Joined
·
73 Posts
Discussion Starter #3
I think my compressor is dead. We hooked some vac lines to it to see if it held pressure. Once we hooked it up, I jumped the compressor. It ran just fine but it wasnt pressurizing the high side at all. My gf's dad said that the impellers are probably shot. Mother******! Im trying to sell it to get this SC for sale. This isnt helping at all. A new compressor is about $260! Plus all the other parts. bahhhh. Ill just sell it as is.
 

·
Registered
Joined
·
1,430 Posts
ah that sucks too bad it wasnt a cheap replacement, oh well... **** happens
 

·
Registered
Joined
·
73 Posts
Discussion Starter #6
There is a prerssure switch on the accumulator. Pull it and put a paper in between the terminals and it will run it. You do this when there is no pressure in the system to activate the pressure switch.
 
1 - 6 of 6 Posts
Top