TCCoA Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
well, ive only had this car for about two months now, and for about 75% of that time, the check engine light has been on. i havent had much time to look into it, but since it was felt as though it was running fine, i let it go. now, when at idle, the car will shake. also sometimes when cruising at 40-50 it will hesitate. so i went to autozone, and came back with p0135, p1131, p0171, p0172, p0175. ive done a little searching, and it seems as thought cleaning my IAC and MAF should take care of the problems. and if not then maybe plugs and wires. just wanted to know if anyone had suggestions/more info before i got started. also, its got about 78000 on it.
 

·
Registered
Joined
·
2,556 Posts
did they not give you any descriptions with those codes? every time i get mine read, it pretty much tells me whats wrong.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
they did, but seeing that it was AZ it was rather vague. all the codes pointed to O2 sensor(s), running rich, etc.
 

·
Registered
Joined
·
921 Posts
Direct from the Chiltons


P0135 - Upstream Heated Oxygen Sensor Heater (HTR 11) Circuit manfunction (Bank #1)


P1131 - Lack of upstream heated oxygen sensor (HO2S 11) switch, sensor indicates lean (Bank #1)


P0171 - System (adaptive fuel) too lean (Bank #1)


P0172 - System (adaptive fuel) too rich (Bank #1)


P0175 - System (adaptive fuel) too rich (Bank #2)

What that all means? I can't say. I'm just giving the codes out so someone who knows can tell us all. I would guess that the O2 is fried(Bank #1). but like I said, Id on't know fo sho.

Or... mayhaps a naughty fuel pressure regulator?
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
just as an update, two O2 sensors, plugs and wires took care of this problem. gonna clean the MAF soon just for good measure.
 
1 - 5 of 5 Posts
Top