TCCoA Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
I've been having some issues with my '92 Cougar LS (3.8L auto).

First off,sometimes it needs to crank quite a bit before it will start. If I start it up for the first time in the morning or whatever,it will start up just fine. But it seems if I park it for about an hour or two it will have the problem.

Second issue I'm having is an erratic idle. A while after I bought the car (a year ago) It started to develop a very high idle. I grabbed a IAC from the junkyard and it lowered the idle quite a bit and everything was fine for a while. Now it's idling erratically and at times it will stall out if I'm stopped for more than a minute (stoplights,drive-thrus ,etc.) I got a new IAC for it and it stopped the stalling issue for a while but it started again not too long afterwards, which leads me to believe I have another issue.

Hopefully someone has run into this before and has some advice. This is the newest car I've owned so far, not to mention being the first Ford product and first fuel; injected vehicle I've owned. Other than this issue it's been a great car for how old it is and how many miles it has.
 

·
Administrator
Joined
·
8,009 Posts
I had a similar problem on an older car. Turned to be the fuel pump.

Joe
 

·
Registered
Joined
·
18 Posts
Discussion Starter #5
Sorry to drag this back up. I have yet to check the psi when it's acting up,but one other thing I should mention is the car runs fine on the highway,but when it comes to around town driving,it has the problem. I like the car but this issue is getting on my nerves.
 
1 - 5 of 5 Posts
Top