TCCoA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
201 Posts
I was tired of not having a tach so I finally got around to installing one, along with a voltometer.

Here are the pics.
Nice.... looks like an exact match on the paint :)

I've got a dual A-pillar gauge pod as well w/ Voltmeter & the A/F ratio in the phatam series... looking to get rid of my dual pod and purchase the triple pod and install a 30lb boost gauge, my A/f ratio, and a water temp. gauge.

So many idea's, but my money tree is not maturing fast enough.:D :( LOL

BTW.... nice pic's. Like how you showed the step's of how you did it. Very helpful!

GOOD JOB.
 

·
Registered
Joined
·
133 Posts
Discussion Starter #4
94t-birdlx said:
What did you use to paint the pod? Was it made to match the interior?
I used Ford interior primer and paint.

Overall, it matched up well.

I believe you can find similar interior paints at Autozone, etc.

BTW.... nice pic's. Like how you showed the step's of how you did it. Very helpful!

GOOD JOB.
I always like to document what I do to save the next guy or gal some time. Currently, I am putting together a write-up.

Thanks for the kind words. Keep us updated if/when you install that triple pod.
 

·
Registered
Joined
·
310 Posts
Looks great Steve but I don't expect any less from you. I didn't know they made tachs so small!

Did you get a chance to make it out to the track? B'dubs was owning me so I couldn't go.
 

·
Registered
Joined
·
133 Posts
Discussion Starter #6
Unherd said:
Looks great Steve but I don't expect any less from you. I didn't know they made tachs so small!
Thanks.

Did you get a chance to make it out to the track? B'dubs was owning me so I couldn't go.
I was up in Northern KY at a Vic meet yesterday. It was nice to finally be able to monitor the RPMs.

Until I get the Vic retuned, I might hold off on the strip.

If you do go out there sometime soon, give me a ring.
 
1 - 6 of 6 Posts
Top