TCCoA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
Maybe someone out there can help me. My AC SUCKS!! It blows where it should, nice and strong, but is BARELY cold.

I have a new compressor, new evap(PITA job), new condensor, liquid and suction lines, new drier...ect. Everything is brand new. I have evac'd and recharged the system, no contamination present.

The AC runs, the lines get cool(not as cold as they did prior to the black death killing my old compressor), but if I even look at the gas, the compressor kicks out, and no AC. I have gone so far as to check the TPS, and everything in the PCM(which is going away this winter...Accel DFI install coming up), but something is definately not right here. I have had three of the shops I do bussiness with look at it, pressures are right where they should be, we thought it was an airflow problem, so we installed a condenser fan, still no difference. Then we thought it might be because the accumulator is so close to the exhaust headers, so we installed in insulator...no difference. We tried by-passing the heater core, thinking it was somehow blending hot air into the ducts...still no luck...

It gets cool, not cold, and the compressor cuts out, as if the high pressure side was overshooting, so we replaced the high pressure cut-out...no difference....Only thing I can come up with is that the pressure is spiking at higher RPMs....but it even happens just idling around sometimes...

ANY IDEAS???? It sucks to not have good AC down here in Florida...I am THIS close to making this car a weekend warrior and givning up on the daily driver side...:2huh:
 

·
Registered
Joined
·
1,544 Posts
There's a WOT cutout relay on there somewhere... might be defective?
 

·
Registered
Joined
·
610 Posts
Is the cycling switch working correctly? Is it short cycling more than it used to? I would look at the cycling switch as I had a similar problem. I replaced it and has worked ever since.

Jim Long
 

·
Registered
Joined
·
803 Posts
You probably have crap in your lines. False pressure readings can be had if you have a clogged expansion orifice. If it is clogged efficiency goes down. Also, the idea that as soon as you get on the gas shows that at load those "good" pressure levels are not really that good and the low pressure switch on the accumulator is opening the circuit since it has no real head pressure, just enough to keep it static.

The factory manual suggests a full system flush and refill with internal parts replacement. Also I have seen where guys will put in-line filters in the lines to prevent any left over crud from all the parts changing out from causing the same problem again.

And WOT cutout is done thru the EEC. There is a wire that runs to the IRCM from it to switch it off.

rm
 

·
Registered
Joined
·
31 Posts
Discussion Starter #5
Thank you...

That was what I thought, as far as crud in the system...I checked it, everything is clean...in fact...everything, compressor, evap, condensor, liquid and suction lines, rec/drier...everything is new...I even went with a new compressor, mainly because I have, in the past, had problems with remans...Silly thing is driving me crazy...

Now, we did have some crud in it one time..right after the install..sandy stuff, we thought the drier must have had a defect...at that point, all we had replaced was the compressor, drier, evap, liquid line, and condenser...so we went back, flushed everything again, installed another new compressor, another new drier..and this time, since it was the only old part left, we replaced the suction line...

I am going to, in all liklihood, have to open the system again..if I do, and I find the crud again..where is it coming from??? These are brand new Motorcraft Compressors, not crappy remans...All lines and everything else is new...where is it coming from???
 

·
Registered
Joined
·
227 Posts
compressor cut out

I know it may be A pita but is there anyway you could leave A high pressure side gauge hooked up and visible while you drive ? You might be able to see if there is some crud that blocks the orfice tube or some other part of the system when the compressor cuts out. I live in s.florida too, its no fun without a/c good luck
 
1 - 6 of 6 Posts
Top