TCCoA Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
187 Posts
Discussion Starter #1
I have a 97 with a 4.6, and the ac is making the car surge forward whenever it tries to cycle on/off. It does it when either ac or defrost is turned on.
I had no ac a couple of years ago, and replacing the ccrm with a new ford unit fixed the issue. As of this summer, I no longer had working ac, it would just blow warm.
Now whenever the car has the ac or defrost turned on, it pretty much idles at 5-600 RPM until the ac attempts to cycle off, the revs then surge to 900 or so, basically like it should if it is operating normally, but it immediately drops back down to 5-600 again. The car wants to lunge ahead a few inches every time this happens, and if I am not hard on the brakes, the car will scare people in crosswalks etc. I have not timed it,but I am guessing that this will happen 3 to 4 times per minute.

Basically, it seems to me that the compressor is on at all times, except for when it tries to turn itself off for a second (when the rpm jumps). Can someone give me some direction on troubleshooting this issue?
 

·
Registered
Joined
·
134 Posts
my 94 bird did the same thing, idle jumping up and down, maybe not as extreme as yours but all it needed was a refill of fresh freon (or whatever they call it now), It's fine now since I had the gas refilled.
 

·
Registered
Joined
·
187 Posts
Discussion Starter #3
Fixed it....sorta.

Well. my surging problem when the ac cycles on/off is fixed.
I swapped my leaking NPI intake for a PI intake and installed new spark plugs.
My old plugs looked fine upon removal, and I think that the coolant leaking from my intake was causing a misfire (no codes), which in turn made the car run bad enough that it caused problems when the rpms changed from the ac cycling on/off.

But what do I know.....just goes to show that general maintenance is important.

Also....PI intake......two thumbs up.
 
1 - 3 of 3 Posts
Top