TCCoA Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
I have a problem with my 97 4.6L V8 (bird) running rich. I burn through about a set of plugs every year and a half. I have FRPP plug wires and motorsport plugs. I used to be able to bark tires from a dead stop but am unble to do so now. I still have to replace my EGR sensor. Injector cleaner helps mid-range acceleration. I also would like to know how many o2 sensors the 4.6 V8 has? there is 93K on the clock and those are factory. Also my battery is only reading like 10 volts. I'll get one this summer (motorsport batteries last long mine is almost eight years old). With new plugs and everything running the car flys. Any way if anyone has any suggestions about what could be causing the lack of acceleration from the low end? I can be reached at [email protected]

Thanks

Nick in St.Louis

P.S.- GO CARDS!!!!!!!!
 

·
Trumpeter Extraordinaire
Joined
·
2,916 Posts
The 4.6L engine thunderbird has 4 oxygen sensors, two before the catalysts, and two after.

This thread was started several weeks ago, and indicates a good deal on oxygen sensors. Howver, you may want to act fast, as I recently heard that the seller has just a few sets remaining...

Regarding that "bogging down" - get that EGR pressure sensor replaced, and see what happens. My mom's Taurus recently had a bogging down problem, and it was cured by replacing the pressure sensor.

Addidtion oxygen sensor info: Jerg2 lists, in this thread, a few places that have competetive pricing for oxygen sensors...it may be worth a look.
 
1 - 2 of 2 Posts
Top