TCCoA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,170 Posts
Discussion Starter #1
The A/C stunk so bad that I replaced the motor a few weeks ago (it was flaky). The odor would be constant.

That did help but when I start the A/C there is still an unpleasant odor for a mile or so. I read something about defogging the A/C system. Anyone have any luck with doing that? Do the evaporator boxes clog up?
 

·
Administrator
Joined
·
8,032 Posts
Might be mold in the vents that's giving you the odor.

Joe
 

·
Registered
Joined
·
871 Posts
Check your cowl panel for leaves and other build up, heater boxes also clog up, your going to have to find the drain and possibly stick a hanger up there to see if its plugged or not. Sometimes they plug up as well.
 

·
Registered
Joined
·
1,273 Posts
yep, chances are the heaterbox is full of junk, and moisture over time has grown mold around the inside of all the plumbing.

you'll most likely have to get inside the box again and clean it out with some antibacterial soap.

otherwise theirs cans of spray at all the parts stores that you shoot down the intake of the airbox while its running and it kills mold and bacteria inside. never tried them, but Ive herd good things. want to say the one we have at orielly is something called Ozium... i suppose you could probably do the same thing with Lysol though :D
 

·
Registered
Joined
·
13 Posts
Put the a/c on high and recirc with the Windows up, and sissy febreeze on the passenger side floorboard close the doors and let it run for about a half hour like that. I used to prep used cars for resale and that's what we did if a trade in was driven by smokers
 
1 - 6 of 6 Posts
Top