TCCoA Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
694 Posts
Discussion Starter #1
Well, i'm back to a problem that I THOUGHT I solved about 4-5 months ago. I replaced my EEC a few months ago when it started dumping raw fuel out of the tailpipes. I put in another EEC, reburned the catch code for the SCT chip i've had for years, and installed it. Everything was fine after that. Just today coming home the CEL came on and immediately starts bogging down, stalling out, running like crap.... just not driveable. These are the SAME symptoms I had last time before the EEC totally died. The thing is the CEL would flicker off and on randomly... and as it appeared the car would die. So, I turned the car off and then turned the key to the ON position and would hear a clicking noise from under the hood... random clicking. The clicking noise was also associated with the CEL light flickering on and off.

This definetly feels like an electrical issue. Im pretty sure the EEC is good. I thought maybe the wiring to the EEC was loose. When I got the car to run normal for a few minutes I tried moving/wiggling the EEC and wiring to get it to recreate the problem.... but nothing happened.

Is it possible the SCT chip is bad and causing the EEC to fail? I sanded down the contacts on the new EEC before installation. The first time I took it to a mechanic when the FIRST EEC went bad, the mechanic said my SCT chip was causing the EEC to fail... but I thought he was wrong... i've had it in the car for 3-4 years before this problem occured. Now its happening all over again, 4 months later and with a different EEC. Any thoughts?
 

·
Registered
Joined
·
694 Posts
Discussion Starter #2
Update, I disconnected the MAF sensor and the car ran better with no issues lol. Im guessing that might be the problem. But I took it to a good car mechanic just now and let him know all about that. Hope to find something out tomorrow.
 

·
Registered
Joined
·
3,726 Posts
When it is clicking, is it the cooling fan that is ON when the CEL is off?
 

·
Registered
Joined
·
694 Posts
Discussion Starter #4
Whenever the CEL came On... the Fan would kick On. That clicking I heard was probably just the fan going on and off repeatedly then eh?
 
1 - 4 of 4 Posts
Top