TCCoA Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
3,391 Posts
Discussion Starter #1
So Every week I have to put AT and I do not know were the hell is going, there are no leaks (not that I know off). What could be causing?! Gauge Temp seems fine, I have bi-passed the heater core because it took a dump on me (I haven't replaced it) :bawling: and winter is coming.

I also noticed a chirping sound (like if it was out of power steering fluid) but the container was full, is my water pump starting to get a dump or what?! It's a 96 cougar with 150k...
 

·
Registered
Joined
·
3,757 Posts
chirping or squeeling has me thinking W/P also. get it hot and park it and put a piece of cardboard under the W/P to see if it's dripping
 

·
Registered
Joined
·
7,758 Posts
Check your radiator on both sides where the tanks are crimped on. I have had two fail at that location and the antifreeze was evaporating before it got to the ground. It was just wet along the tanks and a little at the bottom but nothing on the bottom.

Just my .02. :thumbsup:
 

·
Registered
Joined
·
3,391 Posts
Discussion Starter #6
if its not leaking, it has to be goin somware. happen to have antifreeze mixed in with your oil, or white smoke comein out the exhaust

Nope, Not that I've seen...

I'll check both end and see what's up. I will also check the water pump...

Thanks guys!
 

·
Registered
Joined
·
105 Posts
Check the cap to your reseviour as well, a poor cap will let it evaporate.
 

·
Registered
Joined
·
3,902 Posts
Belts will chirp some when they get wet with water or antifreeze. Leaking WP seals will get water on the belts. I would feel around on the back inside of the WP pulley and see if you come back with a wet finger.
-Rob
 

·
Registered
Joined
·
3,391 Posts
Discussion Starter #10

·
Registered
Joined
·
23 Posts
when u check the radiator is it full ... If it is and the reservoir is emptying all the time and causing the light to come on...well I would check under the reservior where the hose goes to the raidiator and back to the plastic reservoir....that hose will dry rot and not form a good seal and slowly leak out. Mine usually takes about 4 hours to empty and everything in the raidiator stays there .... and the light comes on all the time.
 
1 - 11 of 11 Posts
Top