TCCoA Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
148 Posts
Discussion Starter #1
I believe my MAFS is bad. I go down the road and my car literally dies and then goes again.. it's like it's just losing all of it's power source at once.. but then it catches itself and continues to run.. but while in Park it seems to rev fine.. is this the MAFS?? 4.6l 95 bird -matt-
 

·
Moderator
Joined
·
8,239 Posts
Its MAF dude not MAFs :)

Anyway, pull the codes from it and tell us what they are if there are any codes.

Is it unplugged by chance?

Clean the maf, then reset the comptuter and report back to us.

Could be alot of things without a code.

Bum plug wire, bad plug, clogged fuel filter, dirty maf, bad o2 sensor, the list goes on and on.

JH
 

·
Registered
Joined
·
7,758 Posts
Mine did that about 4 times on a trip back from Atlanta and no codes were thrown. On the 5th or 6th time, it finally threw a code indicating a bad MAF.

But you are describing the exact symptom I had. :(
 

·
Registered
Joined
·
526 Posts
Same situation my Cougar once had. It was before I started doing all my own work and I got charged $280 to replace it. If I had only known....but anyway, mine would cough and act like it would die, then catch again and ping and backfire when you would get on it. Codes would certainly confirm MAF is it's throwing any...
 

·
Registered
Joined
·
7,758 Posts
JustinH said:
Its MAF dude not MAFs :)

Umm, technically: Mass Air Flow Sensor.... MAFS :D
 

·
02 Explorer Pioneer
Joined
·
2,880 Posts
Also when it starts happening try unplugging it and see if it runs better
 

·
Registered
Joined
·
217 Posts
Does it happen to you guys when you first give it gas when the car is still cold? When i do that, the car stumbles, rpms drop and the car almost dies. When it gets warmer, it gets better, but its still evident. Any ideas?
Adam
 

·
Registered
Joined
·
2,806 Posts
Try cleaning it and reseting the computer before replacing it. This is how if you don't know how:

Remove the two torx head screws on the top or the MAF (T20 Tamper Proof) and spray the wires with electrical cleaner. Take out fuse 15 from the underhood fuse box. Turn the key and the car will turn over but not start. Replace fuse and take for a nice drive for the computer to reset.

Of course if it doesn't help the problem then you won't be able to take it out for a drive but its worth a try. I am surprised no one has recomended cleaning the MAF yet since it seems to come up on almost any other engine related thread, go figure.

-Miller
 

·
Refrigerator Raider Hater
Joined
·
11,719 Posts
94 Daily Driven 4.6L said:


Umm, technically: Mass Air Flow Sensor.... MAFS :D
Well then......Airflow is one word, so it would be MAS.
 

·
Registered
Joined
·
27 Posts
I've got a new MAF in my car now.. it's stock and all... no gutting or any of that crap... I got a new 85mm and chip so I won't need it anymore... all I have to do is find a flipping filter that will fit the adapter plate. (the UPR 4 1/4 are on back order)

Anyway... if you need it .. I'll sell you it for cheap. I heck of alot less that 280 bucks


email me cause I don't check my PM's

Hope I can help

BK
 

·
Registered
Joined
·
4,205 Posts
Hey Bill, I've got a brand new 02 GT airbox with filter and all that I'll sell you for $50 + shipping, if you don't want to wait for an adapter. PM me if your interested
 

·
Registered
Joined
·
3,183 Posts
I was told my MAF was bad because i am running very rich. I have a 87mm MAF and MAC cia to install, this should problem. Should be good upgrade IMO, I will try to install today. Let you guys know how it goes....
 
1 - 14 of 14 Posts
Top