TCCoA Forums banner

1 - 14 of 14 Posts

·
Motorboatin' SOB, Headlight Cleaning Guru
Joined
·
6,910 Posts
Discussion Starter #1
i am getting a check engine light that comes on a few minutes after firing it up, but before reaching full operating temperature, then it goes away. it also comes on while traveling 75-80 mph and stays on until i slow down to about 70. my gas mileage seems a bit weak, too. finding an obd1 code reader around here to borrow is a chore, and i need a quick diagnosis. does this sound like bad o2 sensors?
 

·
Registered
Joined
·
2,638 Posts
I am not sure about your diagnosis, but do you know about grounding one of the pins on the OBDI port and counting the flashes? I did it to my '93 Ranger and it was a pain in the butt but it does work and you don't need a reader.
 

·
Motorboatin' SOB, Headlight Cleaning Guru
Joined
·
6,910 Posts
Discussion Starter #3
yeah, i heard of that trick and i got a thread going about that. not much help so far cuz i need a pic.
 

·
Registered
Joined
·
1,890 Posts
big mike said:
yeah, i heard of that trick and i got a thread going about that. not much help so far cuz i need a pic.




there ya go
 

·
Motorboatin' SOB, Headlight Cleaning Guru
Joined
·
6,910 Posts
Discussion Starter #5
what are you using to connect the pins?
 

·
Registered
Joined
·
1,890 Posts
In the pic its just a piece of red plastic so it would show up better. When I ran the test I used a paper clip, works great.
 

·
Baby Huey
Joined
·
3,210 Posts
I have to do pretty much the same thing on my 88 cutlass, except that both pins are in the same harness.
 

·
Administrator
Joined
·
748 Posts

·
Registered
Joined
·
2,472 Posts
Does it drive better cold or after warm up, does it bog under WOT? Though intially it does sound like O2.

To pull EEC-IV codes jumper the top right plug of the larger connector with the small connector.
 

·
Registered
Joined
·
1,890 Posts
Any luck with the codes Mike?
 

·
Motorboatin' SOB, Headlight Cleaning Guru
Joined
·
6,910 Posts
Discussion Starter #11
i cant tell a difference whether its cold or warmed up. no bogging under full throttle.

i havent pulled codes yet.
 

·
Registered
Joined
·
2,472 Posts
Mike, either pull the codes or get a volt meter on the O2. Only other thing else I could come up with is MAF, but I lean toward O2. If so hurry up and change them and stop getting my headers dirty. ;)
 

·
Registered
Joined
·
1,890 Posts
Sounds exactly like what my truck was doing. Changed the 02 today and all is well
 

·
Motorboatin' SOB, Headlight Cleaning Guru
Joined
·
6,910 Posts
Discussion Starter #14
bowez said:
stop getting my headers dirty. ;)
dont tell me that. i sold them along with my entire exhaust :(

yeah, late reply. sue me :tongue:
 
1 - 14 of 14 Posts
Top