TCCoA Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
190 Posts
Discussion Starter #1
This just happened two days ago, i had been getting a quiet screeching noise for a few weeks though (like i needed new brakes). So i thought it was that, then i was coasting through a parking lot and i hear a creaking/grinding metal sound, kinda sounded like a ball joint was gonna break, so i stopped the car. Ne hoo, it makes that creaking/metal grinding noise only at low speed. What the hell is that??
 

·
Banned
Joined
·
538 Posts
Not too sure if this is still an issue or not but Check your Hub nuts on the rear. Also check the Fluid in your rear end. It could be as easy as brake pads flopping around.

Mike
 

·
Registered
Joined
·
190 Posts
Discussion Starter #4
man...talk about digging up old posts. This one was before i even bought my supercoupe. Anyway, problem turned out to be my rear bearings. Got both sides replaced, and that took care of everything. Hope that helps.

-Trey
 

·
Registered
Joined
·
1,610 Posts
care to elaborate? Where are these and how can i test to see if they are bad. Im having very isolated problems like you were. Only happens when car is warmed up at low speeds during cornering. I can get it to do it every time while its doing it... but its pretty hard to diagnose.
 

·
Registered
Joined
·
190 Posts
Discussion Starter #6
I did not replace the rear hub bearings myself, i had a shop do it. They need to be pressed out and have new ones pressed in, as far as i know. It's probably not a job to tackle unless you know what you're doing and you have the correct tools. Any reputable mechanic will be able to diagnose ur problem for sure and fix it. Good luck.

-Trey
 

·
Registered
Joined
·
1,610 Posts
Thanks... ill have them look at it soon. Im not sure if my dads gonna let my borrow any money until i get back from FL so well have to see when they get fixed. Theyve been making that noise/feeling for about 6 or 8 months now so im not too worried.
 
1 - 7 of 7 Posts
Top