TCCoA Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
271 Posts
Discussion Starter #1
I am experiencing a lag/hesitation in the early rpm's and I am experiencing significant power loss. I am hearing a whining wich I believe is comming from the SC. I have heard that SC's do whine normally, but I have also heard that when they go bad they will whine...

What is the easiest to test to see if it is operating normally? I have no cats or resonator, and if I step on it I get 11-12 lbs of boost and I have either a 10 or 15% OD pulley on it as well. The car origionally had 70k on it, but it also had enging knock due to wrong crank bearings.
 

·
Registered
Joined
·
926 Posts
alot of time I have heard that the SC's will leak oil around them Im not to shure but it sounds like you might have some issues with thoes bearings , Keep me posted Im interested in what the problem is
 

·
Registered
Joined
·
271 Posts
Discussion Starter #3
well I have another SC off my other car but it has close to 200k on it, but I did notice when I was took the top off, permanent black marker was inside on the "rotors" (like a date written I don't exactlly remember) so would it be possible that someone may have reconditoned it? I have just been lazy and I don't feel like going through the taking off the SC process again... grrr... I do notice some sepage between the top and the sc on the one on the car now...
 

·
Registered
Joined
·
204 Posts
I've never heard of one of our superchargers going bad and failing like turbos do. What they can do is rattle if they run dry of fluid and that usually seeps out at the front seal so the inside of the pulley gets wet with stinky oil. If it starts to rattle b/c of the bearings they can be replaced and not expensive. I've had serveral SCs apart and all of them had those felt tip marker numbers on the inside of the top. The whine is normal when under boost. Maybe your SC belt is slipping, which could cause a lag or less power than it should, otherwise I would look at other things like vacuum leaks or plugs & wires. Good luck
 

·
Registered
Joined
·
271 Posts
Discussion Starter #5
plugs wires are both new. sc belt is bad it may be slipping... since I swapped SC's, I can hear the sc whine - even idling... is that normal? my old sc leaked bad - this one doesn't...
 

·
Registered
Joined
·
724 Posts
Well among the first things that you can do. Pull of the SC belt and see if you still hear the noise, then you can make sure that its the SC. Next I would check to see how you are sitting for SC fluid. Just remember that the car has to be sitting level and dead cold to check the level, it should be just touching the bottom of the threads. You said that your noticing "seepage" between the top an dhte SC. If you have a gap or a bad seal that would explain all your symptoms right there. If everything seem to check out you can always just swap it with you other one and see of you notice the same symptoms. Grifter and I changed one out right after I had been romping on it hard and it only took us like 1/2 an hour including burnt hands. If you do swap the SC and you notice the same symptoms then I would guess that its probably a vacume leak elsewhere.

Just some ideas.
 

·
Registered
Joined
·
56 Posts
Check around the pulley of the supercharger to see if the belt is slipping, there will be black rubber flakes from the belt. They sell the bearings and seal kit for the supercharger for under $50.00 and is very easy to install. Superchargers do not go bad they just need to be rebuilt. I agree that if you are leaking fluid from the top then you have a leak which is probably causing you all your problems. Seal the top with rtv copper silicone and you should be ok. As for the whine from the supercharger that is normal. When you get that rattle and leaking from the snout thats when it is time for a rebuild.
 

·
Registered
Joined
·
724 Posts
Well some of the earler models of the SC had very noisy superchargers. So many people complained that they changed the internals in teh snout in I think 90 or 91.
 

·
Registered
Joined
·
47 Posts
This bearing and seal kit for the supercharger - where can I get one of those? From Ford, or does someone make it aftermarket? Also, are the internals the same for the '89-'93s, or did they in fact make things a little different after '91?

Thanks alot,

Matt
 

·
Registered
Joined
·
56 Posts
The bearing and seal kit you can get from tbird88. As for the superchargers being different internally from 89 to 91 I am not sure... Sorry
 

·
Registered
Joined
·
724 Posts
The only differance was in the snout. If you so a search over at SCCoA you will find the info that your looking for. the only differance was that they added a spring and a hockey puck like thing in the snout to keep everything together. And you can add that to the ones that didnt have it originaly also. Otherwise the 89-93 superchargers are the same, its just the 94-95's are a hair different.
 

·
Registered
Joined
·
484 Posts
I went through three chargers on my last SC within 4 month time frame. They all made a faint clicking sound that got louder with more RPM's. My warranty was sending them to a rebuilder out of Texas. I later found out he was building them with motor oil instead of SC fluid. At the first hint of a noise, I would change the fluid to new SC fluid, and find and stop any leaks. About all you can do until it goes out for good and it cant hurt.

My second one actually locked up a few times, even with Gatorback belts, that made a horrible noise.
 
1 - 12 of 12 Posts
Top