TCCoA Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Recently I had $8,000 of work done to my engine, including 4.10 gears, SHM forged rods and dished pistons, SLR performance cams, bored .030 over, ported/polished heads, 2500rpm stall converter, CAI, 77mm MAS, custom dual-single-dual exhaust, JBA shorty headers, and B&M shift kit.

For some reason, when we took it to the track to test it out, it ran SLOWER than it had before all this work (about 16.2-16.5 in the quarter). Largely this is due to the 4.10 gears tricking out the speedo into hitting the 105mph limiter at about 75mph, but also the launch is terrible. I've tried all different kinds of launching (torque braking, mashing the pedal, manually/automatically shifting, etc.), but it bogs terribly till almost 3000rpms, when it picks up like it should.

My first thought was that the stall converter hadn't been installed at all or was malfunctioning. That's a possibility, but I've also been looking at a lot of your mods and respective times at the track, and there's no way with all this work done I should be anywhere above 14 seconds, at least! We tested this theory on the way home with my friend's SVT Contour. He's pushing about 250hp with his car (14.5 @ 94), so we got even with him at about 20 or 30 and took off. We did this four times, and every time he pulled away with shocking ease.

Even if I only had 250 hp under the hood (the shop promised me 310), and him with maybe a 600-pound handicap, there's no way he should pull on me like that--it looked painfully effortless. Any help here would be greatly appreciated, as I'm not quite sure where to go from here.

Thanks,
Brian
 

·
Moderator
Joined
·
8,239 Posts
aloha.

sounds like you need a good eec tune.

Contact one of the vendors on this site, they know what they are doing.

JH
 

·
Registered
Joined
·
635 Posts
yeh, i was thinking the same thing. Yer eec doenst know what all you did and all yer functions are prolly out of whack and arent taking advantage of the new stuff. Get a chip...
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Hey thanks guys, I'm looking into a chip right now, hopefully that will fix the problem. It's just so hard to imagine that one little thing taking me from the 16's to the 14's :)
 

·
Premium Member
Joined
·
1,244 Posts
Yeah, but that one little thing is the brains that make everything else work together. Without it, you're toast. I think you need a chip tune since there was no mention of tuning the car with all the rest of the work done.

Pete
 

·
Registered
Joined
·
9,966 Posts
TheBirdBow said:
Hey thanks guys, I'm looking into a chip right now, hopefully that will fix the problem. It's just so hard to imagine that one little thing taking me from the 16's to the 14's :)

www.superchipscutom.com you might be able to find a dealer in hawaii who has the SCT software and get that thing dyno tuned. Hell, with those 4.10s you should hit 13s..

good luck

joseph
 

·
Registered
Joined
·
1,566 Posts
There is no way a stock Contour would outrun that engine with the proper tune. I had a K&N, no mufflers, power pulleys, and 3.73s. I raced a buddy of mine from a stop and on the run. I shut off at 90 but as soon as I grabbed traction, I waxed his you know what. The car ran hard till then but then shut down. I also raced a CRX on the hwy. I had two others with me and all of our luggage. He beat me by about a fender when I shut down and then I heard the whistle of a turbo.

The point is...have it tuned with a chip and on the Dyno. I bet it makes a night and day difference. By the way. What size MAF and injectors are you running. If you need help I think you can find one on the modular forum...I think.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
Oh, I should have mentioned that his car is far from stock. Probably the most modded N/A Contour anywhere, at least that I've seen. Hence his 250hp and 14.9 timeslip. Either way, as soon as the chip comes in he's toast :)
 

·
Registered
Joined
·
1,566 Posts
Even with those numbers you should be faster after a chip. I have another buddy who had a vortec on his Contour. I heard it was fast. He took it off and sold it after it blew his hgs before I rode in it. 14.9? are you sure you dont mean 13.9? My buddy ran his LX Sport with only a K&N and a 75 mm t-body at a mid 15 I think.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #11
Actually, his times are more like 14.5, everybody out here knows that Hawaii Raceway Park is slippery like crazy. People that have raced on the mainland and come out here say it's at least a .3 second difference. Also, I had a CAI, MAF and the custom exhaust and I could never break a 16 flat. Probably proof of how insanely slow this track is, although with my limited slip I never had traction problems, so that couldn't have been it. This is within a few feet of sea level.

seawalkersee:
77mm MAF
stock injectors
 
1 - 11 of 11 Posts
Top