TCCoA Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
166 Posts
Discussion Starter #1
Well, I finally replaced my upper ball joint/control arm on the passenger side yesterday and I was kinda' shocked when I took it for a test run and still heard the same annoying clunking noise from the front right side. What else could this be? Maybe shocks going bad? The lower ball joints still look good and the driver's side ball joints all look decent as well. This clunking is annoying the hell outta' me. Help? Thanks guys!

:2huh:
 

·
Registered
Joined
·
166 Posts
Discussion Starter #3
FordFanatic said:
are you sure the ball joints are good? how about the tie rods?
Well, I guess someone couldn't be positive that they're good, but I didn't see any cracks in the boots on the other ball joints... Tie rods I didn't even think to look at. I'll have to check that out.
 

·
Registered
Joined
·
3,192 Posts
well just because there are no cracks in the boots doesnt mean the ball joints arent bad. i think the way my father used to check them is to jack the car up and then use a nice big pry bar (he has a 6' one in his garage) and lift up on the bottom of the tire with it. there should be no play in the joint. i dont know how old your suspension components are but it probably wouldnt hurt to replace them just to be on the safe side (check some of the other posts about the ball joint falling out while driving), i dont know where everyone has been getting them but you can get the entire lower control arm for like $50. its a good investment in your safety.
:)

edit: one more quick thing, its always a good idea to replace something like suspension parts in pairs, you replaced one side you really should replace the other.
 

·
Refrigerator Raider Hater
Joined
·
11,719 Posts
worn sway bar endlink and/or their bushings causes a clunking.
 

·
Registered
Joined
·
1,012 Posts
I had a clunking noise on the drivers side and after replacing everything (it needed it anyway) the clunk was still there. It turned out to be the sagging door.

Tony
 

·
Registered
Joined
·
253 Posts
I had a similiar problem, after replacing the LCA's I noticed that the shock bushing on them was hosed bad. Haven't heard a sound since getting them replaced. I assume that the clunking was the shock wobbling around in the LCA mount.

Dave
 

·
Registered
Joined
·
217 Posts
i have a annoying clunking sound. i am totally confused what the heck it is. i just finished replacing the upper ball joints today and i still hear it. its driving me crazy. it sounds like its comming from under the motor or something. i hear it when i rock the car side to side in park too.

alan
 

·
Full Metal
Joined
·
4,744 Posts
gopedxr7 said:
i have a annoying clunking sound. i am totally confused what the heck it is. i just finished replacing the upper ball joints today and i still hear it. its driving me crazy. it sounds like its comming from under the motor or something. i hear it when i rock the car side to side in park too.

alan
i agree with greenbird, it is more than likely the swaybar endlinks.

ps, i also replied to your thread "about to go nuts," . later'z.....:D
 

·
Registered
Joined
·
166 Posts
Discussion Starter #10
rocket_dj said:
I had a similiar problem, after replacing the LCA's I noticed that the shock bushing on them was hosed bad. Haven't heard a sound since getting them replaced. I assume that the clunking was the shock wobbling around in the LCA mount.

Dave
This seems like it'd be the closest answer to my question. I'm going to have to check that out when it quits being crappy out around here.
 
1 - 10 of 10 Posts
Top