TCCoA Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1,273 Posts
Discussion Starter #1
wow... I hate these tires :D I have had nothing but trouble with these $400 headaches. vibrating no matter how much I balance them. flat spots after sitting to long that vibrate even worse for a few miles( I mean seriously it’s like getting a massage, and your hands will tingle after a few min holding the wheel) I have already replaced one of them because it balanced really high and started to chop. And the one I ordered in balanced with 2.25 ounce and 3(and my rims are straight as arrows... spun them on the balancer with no rubber to make sure)... you know for being the best tires for muscle cars back in the 70's they sure do suck now... I wonder if they outsourced to china or something... I’m actually missing my cooper cobras.... and that’s saying something since they started dry rotting after about a year, big ugly 1/8 inch deep cracks in the sidewalls :/ Anyway... not really a point to this :D just felt like letting off some steam. Anyone else have this problem? Mine are 265/70/R15 I think... something close to that i know they we dead-on the original tire diameter so my Speedo still works. I’m just hoping they don’t rip my suspension apart lol.
 

·
Registered
Joined
·
1,222 Posts
This is interesting. I have these tires on my 06 Ranger and I am/was very happy with them. I'm starting to wonder now though if a belt or something might have broken inside, because I get this awful vibration between 55-70. I have taken them back to Tire Discounters and they have balanced them. They found one to be out 1/2 oz, but it didn't fix the vibration. They also told me that everything in the front end was tight and looked to be in good shape. I've also checked the driveshaft u-joints and stuff in the rear, and it all seems to check out ok. I can't figure out where the vibration is coming from.

-Rob
 

·
Registered
Joined
·
1,273 Posts
Discussion Starter #5
lol sorry there 245/60/15's... i got messed up. and yeah i agree they usually are very good tires :( wonder what the chances are for getting 4 bad tires in one shot... well 5 since i returned one :D
 

·
Registered
Joined
·
645 Posts
I never had any problems with the two sets I ran. 4 235/60-15s and 215/70-15 front 255/60 rear. Mileage even held up w/ the multiple burnouts lol.
 

·
Registered
Joined
·
1,222 Posts
I never had any problems with the two sets I ran. 4 235/60-15s and 215/70-15 front 255/60 rear. Mileage even held up w/ the multiple burnouts lol.
I think I've got almost 25K on them and the still have more than enough tread. I'm just getting this vibration that I can't figure out. I'm not even 100% sure it's the tires, but everything else seems to be ok. At first I thought I threw a weight or something. I was driving down the road and it all of a sudden started shaking at 60 mph, so I pulled over thinking I had a flat. Anyone have some ideas to check?

-Rob
 
1 - 9 of 9 Posts
Top