TCCoA Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 95 T-bird with a 4.6l. The other day it blew the eec fuse under the hood. I replaced it ..it blew again. After checking the manual I thought It was the fuel pump..replaced it. Still blows fuse. I disconnected all the sensors with a test light between the two fuse terminals in hopes of finding what is causing this short? The only way I can get my test light to go out(with the key on) is by disconnecting the IRCM. HOW DO I TEST THE IRCM? I removed the metal cover to expose the relays. And then I removed the plasic cover off the eec relay. I insulated the contactor on the relay with a piece of plastic and batta boom the test light went out! What does this tell me? Is the IRCM bad? FYI it blows the fuse even with the eec disconnected... I cant believe that my tbird is the only one that has ever had this issue but I cant find ANY answers! If it is a bad wire...where? If it is a ircm where do I get a new one? how much? If this was a chevy I wouldnt have to look far for an answer someone would say "oh 97 camaro...check the red wire bout' six inchs down from the thing-a-bob and you'll see where it is rubbed through"! BUT NO! ITS A FORD AND EVERYONE IS AN EXPERT WITH NO ANSWER! All threads end without an answer! I found a guy who had the SAME problem. Thread ended with no answers!! HELP!! Before I turn into a chevy guy!!!
 

·
3rd Gear Chirper
Joined
·
2,399 Posts
Yup. Bad IRCM, also called CCRM did you try searching under that?

Oh yeah, don't turn into into a bow-tie guy! There's enough of them around here already.
 
1 - 4 of 4 Posts
Top