TCCoA Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
798 Posts
Discussion Starter · #1 ·
I need to know what is on the driver side of the car, in front of the front wheel. If you pull down the shield you can see a black box, and what appears to be a pump.

I don't know what it is, and Haynes manual doesn't say anything about it, but it's making a grinding noise all the time.

If I start the car and attempt to press in the brake pedal, I get the grinding noise through the brake pedal that rattles the car. Barely pressing in the pedal will even lock the breaks up.
 

·
Registered
Joined
·
798 Posts
Discussion Starter · #2 ·
Update

After about 40 minutes of sitting, and after almost completely draining the battery, the noise and symptoms have gone away.

However, is someone can still tell me what exactly those two things are, I'd appreciate it.
 

·
Registered
Joined
·
1,548 Posts
Well, it certainly could. The ABS system can be scanned for codes like the EEC system for the engine and trans. I'd suggest starting with that, to see if any codes were stored.


cheers
Ed N.
 

·
Registered
Joined
·
798 Posts
Discussion Starter · #6 ·
Update: Problem completely went away till late lastnight. On my home from Salem, IL Traction assist turned off, and ABS light came on out of nowhere.

I stopped the car and turned it off, and then turned it back on...lights went out.

Later I stopped at McDonalds drive through, and the brakes completely locked up on me, and the grinding noise came back. The noise sounds exactly like the sound you get locking up the brakes and having the ABS come on.
 

·
Super Moderator
Joined
·
12,733 Posts
I read here before about a control box or relay for the ABS system being bad...

I'd search for those...
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top