TCCoA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
Ok, I have gone through two sets of brakes in less than Six months. It has mostly been the front pads that have gone but I have noticed that the rear drums are almost always making a grinding sound on the passenger side. From time to time the brake peddle will grab and stick after I release pressure from it. If I pump the brake it will release or if I just let it go after a few seconds it will release. I have checked the brake fluid and it is at a normal level. Has anyone ever had this kind of problem and/ or any ideas as to what the problem is?
 

·
Registered
Joined
·
148 Posts
i havent had this problem but you might want to check all the lines and check your master cylinder or something along that line.
 

·
Registered
Joined
·
1,544 Posts
How many miles on the car? Sounds like you're not getting full travel out of the calipers... might want to take them off and do a little cleaning and see if that helps. Even in AZ you might have some rust or crud buildup. Check your emergency brake cable too... doesn't affect the fronts but could cause the rears to drag if it isn't releasing all the way.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #4
My bird has 180,970 miles on her. I never really checked the calipers the last time that I changed the brakes, I will have to look into that. Thanks
 

·
Registered
Joined
·
2,894 Posts
Beyond the calipers, you may have an issue with your master cylinder. Do you have ABS? If so, are you getting a lit Anti-Lock light or if not, a lit Brake light? I ran into a similar problem with mine, which turned out to be a failed ABS master cylinder. My entire brake system was redone before that, new calipers and pads.

The brakes would be mush when applied, then the brakes would not want to release after a stop. Very dangerous. I would have to get the rpms up to about 2000 before the system would slack off.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #6
I don't have ABS on my car, (Thank G). I did notice that my E-brake cable was loose up by the drivers side door rail. It might have gotten bulled back by something that was on the road. Will check it out and see.
 
1 - 6 of 6 Posts
Top