TCCoA Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
552 Posts
Discussion Starter #1 (Edited)
Here's some facts about the transmission:

110.000 mls.
Replaced with updated accumulators and springs and installed a 1996/1997 oil pan (25.000 mls ago),
Derale aux tranny cooler (installed 1000 mls ago),
flushed and new Mercon V and filter (1000 mls ago),

Noise is noticable when in D or R (using the brake at the same time) and not when it is in Neutral or Park.
It still shifts great!
What could it be and if it is the EPC is it hard to replace?
Thanks for all the input!

Btw I replaced the IAC a year ago...
and I searched the forums, it is just that I would like to have many opinions as possible before starting to order parts and stuff.
 

·
Administrator
Joined
·
8,249 Posts
Probably the valve body. Do a search, I think you'll find out what to do.

Joe
 

·
Registered
Joined
·
552 Posts
Discussion Starter #3
Ok, so do I have to replace the valve body itself?
 

·
Registered
Joined
·
1,998 Posts
My 1995 did the same thing. I replaced the valve body and the springs and was all set. Its not that hard to do if you have some skill.
 

·
Registered
Joined
·
552 Posts
Discussion Starter #5
Thanks, I will look for a different valve body.
 

·
Registered
Joined
·
4 Posts
I know it's a bit of an old post, but wondering what the solution was. I have similar issue in my 92 3.8 L auto t bird. I would describe it as more of a rattle then a buzz but other then that symptoms are the same. It will happen in gear, foot on break. Rev it at all and it will rattle faster for a second and stop. Seems to shift fine as well. My thought was torque converter, and was going to pull the tranny Saturday to replace it, but now I'm having second thoughts. Fluid has been replaced and no metal on the magnet
 
1 - 7 of 7 Posts
Top