TCCoA Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
Recently my '95 tbird has developed a rattling noise up front.

A while back I replaced the upper control arms and ball joints with moog parts.
@ that time everything seemed tight and in good condition.

I jacked it up the other day, and can't find anything loose up front.
The tie rod ends have a tiny bit of play in them, but I don't think they would cause this type of noise.

It's driving me crazy, any suggestions?
 

·
Super Moderator
Joined
·
9,250 Posts
Probably the sway bar endlinks.
 

·
Registered
Joined
·
1,485 Posts
Try replacing the tie rods. My other bird had a rattle that was crazy loud. I didnt think it was the tie rods either because I couldnt find any play in them but i changed them anyway (they were stock 150k on them)and the noise was gone.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #6
Got it up on stands, end links look like a possible source.
However the lower ball joint boots are not looking too good now.
2 years ago I replaced the UCA's, looks like it's time for the LCA's.

Everything else is tight inclding the TRE's...and the outer TRE's were already replaced.

Any tips on the LCA replacement???
 

·
Registered
Joined
·
45 Posts
Discussion Starter #8
Buy Moog.
Check...I bought them (LCA's) @ the same time as the uppers.

One down, one to go....those stupid end links are being a PITA though.
The ends attached to the sway bar are proving to be quite the challenge.
Other ends popped right out with a little persuasion, not so on these...
 

·
Administrator
Joined
·
8,034 Posts
One down, one to go....those stupid end links are being a PITA though.
The ends attached to the sway bar are proving to be quite the challenge.
Other ends popped right out with a little persuasion, not so on these...
Try this. I borrowed Bangster's picture. It worked like charm for me!



Joe
 

·
Registered
Joined
·
45 Posts
Discussion Starter #10
looks like a tie rod puller? I'll check the parts store rental selection tomorrow.

Got the 2nd LCA installed...

Anybody got torque specs handy?
I'm assuming snug everything up, but torque down with the weight of the car on suspension?
 

·
Super Moderator
Joined
·
12,023 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #12
Thanks....everything is torqued to specs now....just have to wait for some more parts.

end links, and a front hub:mad:

I got it all back together(minus the end links) and the passenger side is loose.

What I thought was a tiny bit of play in the TRE's (or lower ball joint), is actually the hub.

So...ordered the end links online since they're way cheaper than anyone local, and a hub assy.

So now it sits on stands with a plastic bag over the spindle to fend off rust.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #13
Got the hub yesterday, and installed it today.
The front end is nice and tight now, and RATTLE FREE:xpcool:

Even found my coolant leak!!! YAY!
It's the freee plug behind the starter...:(

The car needs and alignment now (duh) the steering wheel is crooked now.

The steering is fairly stiff, but the power steering fluid looks pretty nasty.

So the next two tasks will be;
Flush the PS fluid
Replace the leaky freeze plug FUN STUFF. Thinking I'll use one of the rubber expanding plugs otherwise I'd have to pull the engine to replace it with a real one.
 

·
Registered
Joined
·
7 Posts
Check...I bought them (LCA's) @ the same time as the uppers.

One down, one to go....those stupid end links are being a PITA though.
The ends attached to the sway bar are proving to be quite the challenge.
Other ends popped right out with a little persuasion, not so on these...
I did this exact same job on a 98 Mark VIII (same parts as the t-bird) this past weekend. Likewise I had trouble with the end links being frozen into the sway bar and there's no room to reach the link with a hammer and punch like I had used on the other end.

Fussed and cussed for an hour or two, then I regained my composure and wedged a large pair of vice grips real tight onto the old end link, in between the "ball" and the swar bar. Yanked real hard on the end of the vice grips several times and they popped on out. It needs to be a fairly large pair to give you enough grip and leverage.
 
1 - 14 of 14 Posts
Top