TCCoA Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter #1
ok guys here is my problem when i take off from a stop i press the gas and it kinda hessitates and then it accelerates this happens mostly on cold start ups and when it warms up it isnt that bad...i changed the cam sensor and the tps and it kind of helped when i changed the cam sensor now i can accelerate pretty well ,does any one know what my problem might be? and how can i find out if your maf is bad? i ordered plugs wires and coils so hopefully that ll fix the problem.also when it hesitates the rpm shoots down and then back up when it kicks back in and takes off idk.im baffled...
any help will be greatly appreciated.......
 

·
Registered
Joined
·
975 Posts
ok guys here is my problem when i take off from a stop i press the gas and it kinda hessitates and then it accelerates this happens mostly on cold start ups and when it warms up it isnt that bad...i changed the cam sensor and the tps and it kind of helped when i changed the cam sensor now i can accelerate pretty well ,does any one know what my problem might be? and how can i find out if your maf is bad? i ordered plugs wires and coils so hopefully that ll fix the problem.also when it hesitates the rpm shoots down and then back up when it kicks back in and takes off idk.im baffled...
any help will be greatly appreciated.......
Check to be sure you aren't taking in unmetered air. My car did this when the violin case came unattached from the throttle body, it took 3 minutes with a straight screwdriver to fix...
 

·
Registered
Joined
·
975 Posts
Its a large restriction on airflow...not that it matters a lot with regards to a 94/95 intake setup anyway as its not on your later 96/97 style intake.
 
1 - 7 of 7 Posts
Top