TCCoA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter · #1 ·
alright i'm new here so don't pick on me but i got a problem
my car lags or hesitates or whatever u wanna call it when u try and accelerate fast. like if are just normally driving then stand on it the engine seems to bog down and u still just slowly creep up to speed. then sometimes if u lay off the gas and then go back on it it goes away but most of the time it just happens again. i haven't noticed any real trend as to when it happens besides when i want to go fast. i'v had the transmission flushed a couple months ago and that didn't fix it. if u guys could help me out that would be great
 

·
Registered
Joined
·
45 Posts
Hopefully you are familliar with the Mass Air Flow Sensor. If not, check out the tech articles. Anyway. First thing you should try to fix this problem is to clean the wire filaments on the MAF. Use a Q-tip and rubbing alcohol. Be careful not to bend the wires or break them. Give this a shot and post with results.
 

·
Registered
Joined
·
621 Posts
KcBirdFan said:
Hopefully you are familliar with the Mass Air Flow Sensor. If not, check out the tech articles. Anyway. First thing you should try to fix this problem is to clean the wire filaments on the MAF. Use a Q-tip and rubbing alcohol. Be careful not to bend the wires or break them. Give this a shot and post with results.
If you don't wanna break something that'll cost you $200, then you can also get some electronics cleaner (spray kind) and a bottle of compressed air (from Radio Shack) and clean it that way.

Just spray, and let it sit, spray again with elec. cleaner, then just spray it all away with the compressed air. Repeat until you think it's clean. This also works well if you dont have access to tamper proof torx bits.
 

·
Registered
Joined
·
1,798 Posts
mine did it to...

I have a lag right when i start it up, after the idle comes back down. If i floor it then, the idle will drop down. I already cleaned the MAF and it is spotless. Any ideas?
 

·
Registered
Joined
·
477 Posts
Busted torque converter?

Pat
 
1 - 6 of 6 Posts
Top