TCCoA Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
3,183 Posts
Discussion Starter #1
How can I fix this? It reads close to 8-10mph off! What can I do?
 

·
Formerly Fdawg97LX
Joined
·
3,186 Posts
KrAzyT said:
How can I fix this? It reads close to 8-10mph off! What can I do?
try replacing your speedo gear, your might be worn.

Frank
 

·
Trumpeter Extraordinaire
Joined
·
2,916 Posts
Did part of the gauge face replacement procedure include removing the needle? If so, check the post the needle seats on, and make sure it's not bent, or out-of-perpendicular.

It also may be as simple as repositioning the needle again. Does the needle rest on the peg when the car's not moving?
 

·
Registered
Joined
·
3,183 Posts
Discussion Starter #5
yes, it doesnt move untill im doing about 15 then it sky rockets
 

·
Trumpeter Extraordinaire
Joined
·
2,916 Posts
I suggest removing the speedometer, and giving it a close inspection. It sounds like the "needle post" is rubbing, or bent...I've been there before, and what you describe is very similar to what I experienced.
 

·
Moderator
Joined
·
8,239 Posts
thats the main reason why I don't have white faced guages in my car.

Very easy to screw it up. Make sure your gas guage is accurate before you find out that its stuck on full.

The easiest way to fix your problem is to buy a junkyard speedo, and spin it back to your mileage to make it accurate.

JH
 

·
Boom.
Joined
·
5,238 Posts
That's why my temp gauge doesn't work as well!

The speedo and tach are different than the other four though. It shouldn't be too big of a deal, you don't have to replace it in exactly the same position.

On a side note, for the four aux. gauges, here is an installation tip:

Cut a 2 mm or so wide strip out of the face starting from the bottom of the needle hole and going down. By doing this, you can slip the face in without removing those little POS needles and you can't see the cut because of the bezel. I really wish I woulda thought of that earlier, now I have to buy a new temp gauge.

Sorry for the tangent.
 

·
Registered
Joined
·
1,431 Posts
JustinH said:
thats the main reason why I don't have white faced guages in my car.

Very easy to screw it up.
....same reason I don't either (even though I bought a set).

Frustrating, ain't it..........?
 

·
Registered
Joined
·
589 Posts
Being a smart-a$$ won't get you any help.

I had the same problem when I did my guages. So I went to a very unused road at about 11:30p.m. and did a test. With the dash apart I pulled the needle off and put it back on, leaving it just barely on. Then I set my watch and trip odometer and drove at what the speedo said was 30mph for 1 mile. When I got to 2min and 1 mile and I knew it was right. It took a few times moving the needle to get it right. Then, as an additional test, I drove on the interstate at 60mph for 1 mile and it took 59 seconds, so the speedo is prettyu darn accuarate now. Of course, if you have different gears, or bigger rear tires, this method will be a little flawed. But it worked with my stock stuff.

Preston
 
1 - 11 of 11 Posts
Top